summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-17 09:10:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-17 09:36:49 +0200
commitf56d00c87d31bcfa50848926d8a19d224555ac6e (patch)
tree6ff0ad4311041514f12b36b26c72cc0f1a5bc2cc
parentdev-python/sortedcontainers: Bump to 2.4.0 (diff)
downloadgentoo-f56d00c8.tar.gz
gentoo-f56d00c8.tar.bz2
gentoo-f56d00c8.zip
dev-python/pluginbase: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pluginbase/Manifest1
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
index 9684ae35d467..26914715dadd 100644
--- a/dev-python/pluginbase/Manifest
+++ b/dev-python/pluginbase/Manifest
@@ -1 +1,2 @@
DIST pluginbase-1.0.0.tar.gz 41795 BLAKE2B 68d7704b52db39af4f0c2e1f790802eb5f2fd15d91726752605901b3e8a3c736204fad93d96b5dd1a4199586b4d9b42895cbe8290acaed1b4051e8103efb43f9 SHA512 95c3b770980fa5ec745b8d788df29c6219ed6e5af7666f9830d56c6acae01f90831655127bcef69b2dfc423d09429373ae7d4c8b45c76c62a41f909d0747c0a0
+DIST pluginbase-1.0.1.tar.gz 43588 BLAKE2B 8d72dc0afcf4e4e65670902bd3f28a1a36de7f7cc11fd56c624f871ced39e8b989bc6ac74d64e4f96b3bf32f0f4e187ae8b517f9a09cac94b7a735ffb08ec55b SHA512 20844fb78daf3e03a7a8013f82a059bf6b0723a184e89061ce5cb674b5a978900623f2eceed56fc9f9a34410e7e6ca8d41a5ac0a21e374b1b3ce32d4e522348e
diff --git a/dev-python/pluginbase/pluginbase-1.0.1.ebuild b/dev-python/pluginbase/pluginbase-1.0.1.ebuild
new file mode 100644
index 000000000000..b0a0602f7938
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}