summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 08:58:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 10:25:59 +0200
commitf58491b278f94eee20fb3a808643f873554c29e1 (patch)
tree6ad29e33276f051be4de231da175cdf31fb9d67b
parentdev-python/botocore: Bump to 1.25.5 (diff)
downloadgentoo-f58491b2.tar.gz
gentoo-f58491b2.tar.bz2
gentoo-f58491b2.zip
dev-python/boto3: Bump to 1.22.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.22.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e73ab200bee3..3af90a0fc605 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.22.1.tar.gz 493753 BLAKE2B bd58778f89b792b3203b4b8f86edaca2149ebc24
DIST boto3-1.22.2.tar.gz 494671 BLAKE2B c9b72c6a4b667772147235c5791ac4d08adb9e4bd690ea9e369ce712fd705dcc89b2fea4f5b2c580702cc4eb5064b3e46f1237de15e5dd812e2b88c54144d665 SHA512 ecf5d77fb5128a79001a0ccf2e141197d23c0a24d61517e191058de24498d63b13e351fb8e0bfe28f1c58c676d44b2e7f98bd80c41a2510c61d737e086c1010b
DIST boto3-1.22.3.tar.gz 495091 BLAKE2B a917cfec2cb77f9c639160be06f610855b625a9cf55858e0df4602823d6b068a0e188ee911c40255db9fa88b8e20d8b0354948be36e6bf4923b2e4cc45c30524 SHA512 1b12f40b981faf110a76af2418b2afa6fbcfd1ec01bbc842c2c75518245ca11a7d9bc7d5704965246008d43005e7a7a839cdfee7a2e49786ff543bddd1a41c02
DIST boto3-1.22.4.tar.gz 495554 BLAKE2B 4c06e2101bcc96e4fab7e088f8593c7b1cfd2b07431d4cd062666df6c1f5d55d9b7fb594268e9a86c4793d35bc3d8de2644244728cf62833dfefb62525eedbdc SHA512 26dbd9ed1af900f7466a1767ada3fb8ee86fa09ca21733f857e2748d98525661fc76e69d75440fe913260e75245cf30298493417d055399a242af0aedaffd349
+DIST boto3-1.22.5.tar.gz 495793 BLAKE2B df31095d43413694ecdefbd641b3f5b54d6c45181752c17fa2558930ce1ef92a6245a4b74503ec8ce0c94273ab47eb2c2868893fb95217a864fe6cc9a39f0a6c SHA512 63124dc8d21273dd80d10b18e14c9e0a0fda449c18a4a4b585a4c8a98ab5c0c10a344d3bf3ddc4306c294fc77339a80bd38fbba335ef71350c81564182c581f2
diff --git a/dev-python/boto3/boto3-1.22.5.ebuild b/dev-python/boto3/boto3-1.22.5.ebuild
new file mode 100644
index 000000000000..23a4a6fecbae
--- /dev/null
+++ b/dev-python/boto3/boto3-1.22.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}