summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Fröhning <misanthropos@gmx.de>2022-12-21 17:43:03 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-01-02 16:17:51 +0100
commitf5899c42ffbab83bd087c0140b9b8dfd565fe135 (patch)
tree7255c9ef7761cc4d80bc1b8c16859ee6f52a9afa
parentdev-python/pygments: Bump to 2.14.0 (diff)
downloadgentoo-f5899c42.tar.gz
gentoo-f5899c42.tar.bz2
gentoo-f5899c42.zip
dev-cpp/string-theory: bump to 3.6
Signed-off-by: Richard Fröhning <misanthropos@gmx.de> Closes: https://github.com/gentoo/gentoo/pull/28732 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-cpp/string-theory/Manifest1
-rw-r--r--dev-cpp/string-theory/string-theory-3.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/string-theory/Manifest b/dev-cpp/string-theory/Manifest
index c71a11b8be85..b1a156c5f269 100644
--- a/dev-cpp/string-theory/Manifest
+++ b/dev-cpp/string-theory/Manifest
@@ -1 +1,2 @@
DIST string-theory-3.5.tar.gz 589905 BLAKE2B c2bc926b8568efc1fbe27861619bd8249ad788297dd537cff393d212b3bb12a529847b740fc8ba82dc28501fb05800eb8debf3e4832cf145b5c13882ac45e900 SHA512 30300155e64ace8197ed531baffe4e835c269ac10d6857ac9f29501e0a1f69965994d6f2fa2e64544e7d441de635e2d370be24efcf00a0d24066730d19f022a6
+DIST string-theory-3.6.tar.gz 590461 BLAKE2B e8441ead9b13e8f107c47d0695ca669f40558567590b85310903f550edf2d4cbb8622f36857b9563d33a629398358e33024c97b97a8f151a3899f9cee30ee237 SHA512 2bbd8e6c5c2501cc9616ee6a77b60a7cac5e7c9fa58d6616f6ba39cfdee33dc1b072c5d1b34bd2f88726fb4d65d32032595be7a67854a2e894eb3d81d4a8eea9
diff --git a/dev-cpp/string-theory/string-theory-3.6.ebuild b/dev-cpp/string-theory/string-theory-3.6.ebuild
new file mode 100644
index 000000000000..1e683f2fff92
--- /dev/null
+++ b/dev-cpp/string-theory/string-theory-3.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A flexible modern C++ library for string manipulation and storage"
+HOMEPAGE="https://github.com/zrax/string_theory/"
+SRC_URI="https://github.com/zrax/string_theory/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/string_theory-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # Drop -Werror from bundled gtest
+ # bug #766468
+ sed -i -e "s/-Werror//" test/gtest-1.10.0/cmake/internal_utils.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DST_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./st_gtests || die
+}