summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 11:20:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 11:26:38 +0100
commitf58d22201d7272059e350c702198532d4eeabef1 (patch)
treeadb71daaf249f4c3006b57a2abc45e41799fc459
parentdev-python/blosc: EAPI 8, PEP517 (diff)
downloadgentoo-f58d2220.tar.gz
gentoo-f58d2220.tar.bz2
gentoo-f58d2220.zip
dev-python/PyGithub: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyGithub/PyGithub-1.55-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/PyGithub/PyGithub-1.55-r1.ebuild b/dev-python/PyGithub/PyGithub-1.55-r1.ebuild
new file mode 100644
index 000000000000..c2405edca9b5
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.55-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest