summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-19 21:22:55 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-19 21:22:55 +0300
commitf5b0667b97e60bd58b0fc5675e13299ee6d73f16 (patch)
treefe2b75cf48f1a26127420682b04cbbb5782259c6
parentwww-apps/drupal: drop 7.95 (diff)
downloadgentoo-f5b0667b.tar.gz
gentoo-f5b0667b.tar.bz2
gentoo-f5b0667b.zip
www-apps/drupal: add 9.4.14
Bug: https://bugs.gentoo.org/904675 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-9.4.14.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 0c1b656dbc03..f1c13e22f373 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
DIST drupal-10.0.5.tar.gz 17424348 BLAKE2B 8ccaf40e3e082906c89536ab7b4e5ca02fe7f98becb590e1e9740b2cca56657a9f4f1fc636de014007673ad3001bc1888511bcf645772b8bf514becd0cf6a9de SHA512 650c45e285fd805e1d311881c66485c407b2f4b3aa9a379893f226d55e7be978c3ff1c7a0ee061e213a3aab9bff8fddcf1339131454d6b29d5c8a03936124362
DIST drupal-7.96.tar.gz 3381093 BLAKE2B 5b9468cf1805697649f7414695f1dda3e1f79bdd89213367f86b5c2722a3b6c96f9eb225871ce86ccef246eebbad54fc895761c6fe3e8480ca31f2bbd399aedf SHA512 50904f98bf090c3c6d77fa962f9b64c0b0506584337af0ae3ca964f3216a884cb7597f85c209496777390c97fd010fc888bb5d1db4ee08748dc79a37bef14dc6
DIST drupal-9.4.12.tar.gz 21629697 BLAKE2B ffade207c552cbcdc02bfdee672a6f628bb74dbc1bf3e6f276482c838559a7fa195e1c919da6119bdd1edce3b2032ecfb2a9c6694e8894035b22640011d9d92a SHA512 a4e09dbdc6255a82a5948f30f458ed89a0e930703830023116627097f12c2e27c4b0c42feaec21c89db791976a5bd4d2c05d9c02a710384fe4978489ceb78954
+DIST drupal-9.4.14.tar.gz 21636221 BLAKE2B e09ae96efb6037be6c9ebcc6785eef6c75cae2988f41aec8c76c761259beb45063ed013f9e5680d1059f0c3051926f08adfc524266e35948814ccb0ca2492806 SHA512 84df434ffaa35b2ef8aef877196732f1038f47e2028091c3b7de47c686f8767ad091573fee531c9d765064b33b94d727258c390c4159d106ef2cbd6e186423f1
DIST drupal-9.5.5.tar.gz 22560005 BLAKE2B 5a79e0d20273e59e1ad88039fb263fa68397d51bc6f614db8e6396d24169cd7b8314e4a0e26f558a0d8a421b0089210c68a26cac3a0d0205421fde52efd4e6f1 SHA512 d965f5e251bc9eb6f392455724b6321ac3c0e6d134ffbff208748aca397dc98c8ff97d2e1ff2369bf97ba8c9416fc0c5d779b33a194af16343ebc584a8cade68
diff --git a/www-apps/drupal/drupal-9.4.14.ebuild b/www-apps/drupal/drupal-9.4.14.ebuild
new file mode 100644
index 000000000000..cfe37862af18
--- /dev/null
+++ b/www-apps/drupal/drupal-9.4.14.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-9 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}