summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-18 15:01:29 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-18 15:01:29 +0100
commitf5b9fdcdaeaf9cf947298a9d4d0ac64fdb52fc77 (patch)
treeb46c6aa0e8ae17399b5e9c1b8f944d708d764e3f
parentnet-analyzer/knocker: Port to EAPI 7 (diff)
downloadgentoo-f5b9fdcdaeaf9cf947298a9d4d0ac64fdb52fc77.tar.gz
gentoo-f5b9fdcdaeaf9cf947298a9d4d0ac64fdb52fc77.tar.bz2
gentoo-f5b9fdcdaeaf9cf947298a9d4d0ac64fdb52fc77.zip
net-analyzer/dnsenum: Port to EAPI 7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-analyzer/dnsenum/dnsenum-1.2.2.ebuild15
-rw-r--r--net-analyzer/dnsenum/files/dnsenum-1.2.2-remove-extension.patch62
2 files changed, 68 insertions, 9 deletions
diff --git a/net-analyzer/dnsenum/dnsenum-1.2.2.ebuild b/net-analyzer/dnsenum/dnsenum-1.2.2.ebuild
index 166ae344f4ec..ac19ef55f4d4 100644
--- a/net-analyzer/dnsenum/dnsenum-1.2.2.ebuild
+++ b/net-analyzer/dnsenum/dnsenum-1.2.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="A perl script to enumerate DNS from a server"
HOMEPAGE="https://github.com/fwaeytens/dnsenum"
@@ -10,10 +10,9 @@ SRC_URI="https://dnsenum.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="dev-perl/Net-DNS
+RDEPEND="
+ dev-perl/Net-DNS
dev-perl/Net-IP
dev-perl/Net-Netmask
dev-perl/Net-Whois-IP
@@ -23,11 +22,9 @@ RDEPEND="dev-perl/Net-DNS
S="${WORKDIR}"
-src_prepare() {
- sed -i 's|dnsenum.pl|dnsenum|g' dnsenum.pl || die
-}
+PATCHES=( "${FILESDIR}"/${PN}-1.2.2-remove-extension.patch )
-src_install () {
+src_install() {
dodoc *.txt
newbin ${PN}.pl ${PN}
}
diff --git a/net-analyzer/dnsenum/files/dnsenum-1.2.2-remove-extension.patch b/net-analyzer/dnsenum/files/dnsenum-1.2.2-remove-extension.patch
new file mode 100644
index 000000000000..751d673fed2d
--- /dev/null
+++ b/net-analyzer/dnsenum/files/dnsenum-1.2.2-remove-extension.patch
@@ -0,0 +1,62 @@
+--- a/dnsenum.pl
++++ b/dnsenum.pl
+@@ -1,11 +1,11 @@
+ #!/usr/bin/perl
+ #
+ #
+-# dnsenum.pl VERSION 1.2.2
++# dnsenum VERSION 1.2.2
+ # This version: - Improvement of output
+ # - Added DNS Server Fingerprinting
+ #
+-# dnsenum.pl: multithread script to enumerate information on
++# dnsenum: multithread script to enumerate information on
+ # a domain and to discover non-contiguous ip blocks.
+ #
+ # 1) Get the host's addresse.
+@@ -45,7 +45,7 @@
+ #
+ # Special thanks to all perl developers.
+ #
+-# please see perldoc dnsenum.pl for options and arguments
++# please see perldoc dnsenum for options and arguments
+
+ use strict;
+ use warnings;#it complains about uninitialized values when it doesn't find address in RR; need to fix later
+@@ -71,7 +71,7 @@
+ my ($timeout, $delay, $pages, $ipcount, $ipvalid) = (10, 3, 20, 0, 0);
+ my ($output);
+ my $writer;
+-my $program = 'dnsenum.pl';
++my $program = 'dnsenum';
+ my $wildcards = 'pseudorandabcdefuvwxyz0123456789.';
+ my $VERSION = '1.2.2';
+
+@@ -1365,15 +1365,15 @@
+
+ =head1 NAME
+
+-dnsenum.pl: multithread script to enumerate information on a domain and to discover non-contiguous IP blocks.
++dnsenum: multithread script to enumerate information on a domain and to discover non-contiguous IP blocks.
+
+ =head1 VERSION
+
+-dnsenum.pl version 1.2.2
++dnsenum version 1.2.2
+
+ =head1 SYNOPSIS
+
+-dnsenum.pl [options] <domain>
++dnsenum [options] <domain>
+
+ =head1 DESCRIPTION
+
+@@ -1673,7 +1673,7 @@
+
+ =head1 README
+
+-dnsenum.pl: multithread script to enumerate information on a domain
++dnsenum: multithread script to enumerate information on a domain
+ and to discover non-contiguous ip blocks.
+
+ =head1 PREREQUISITES