summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-04-28 10:34:18 +0200
committerHans de Graaff <graaff@gentoo.org>2024-04-28 10:35:25 +0200
commitf5c4ebe6709dcb769ce8a79e3997145791207761 (patch)
tree6abe21d6647f25f7e0e93328f1ae2cc5c6da167b
parentwww-apps/nanoc-cli: add 4.12.21 (diff)
downloadgentoo-f5c4ebe6709dcb769ce8a79e3997145791207761.tar.gz
gentoo-f5c4ebe6709dcb769ce8a79e3997145791207761.tar.bz2
gentoo-f5c4ebe6709dcb769ce8a79e3997145791207761.zip
www-apps/nanoc: add 4.12.21
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--www-apps/nanoc/Manifest1
-rw-r--r--www-apps/nanoc/nanoc-4.12.21.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index cc2c30050c3d..d5de4ef82d17 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -2,3 +2,4 @@ DIST nanoc-4.12.16.tar.gz 350823 BLAKE2B 8196589290b5120b74bd2063e60f1fad14af98f
DIST nanoc-4.12.17.tar.gz 350964 BLAKE2B ca19c259eac8005f2612f61b902005d43196e3e01e8bb0c7a77f9f68bc27486ad6e6e9860420817a633b9a48973f7d98689046cbdb6fe4c185ae18583168d6d2 SHA512 d5a8d3711642f65078102be9317ac2b7db3635c5ff5616d2c05fd917e5cba76a8a21ceeb0a84565723d334f8d62cb55c8097eac07c9bc30f783916c8d312b8c1
DIST nanoc-4.12.19.tar.gz 352620 BLAKE2B 1e6f7e4b49ffd52f985c8a8e4f33401b03abf64569c719a888c603cc8cf1cc2409cf5513dccaa3517bc2d4180e60bec4060db7672d999c486bc4e2138e272946 SHA512 0118eda03479bbdc75098e789ab1095942dfc8967dc6f628e07a93826241845df253eb5701803df2386cf56aaabf6670ed3e8589dcfdcdd331a13def3b05374c
DIST nanoc-4.12.20.tar.gz 355843 BLAKE2B 44974de8d84af651f636f369206875a42aa349f78a98d6425cea5d65cc30a5bcbbc10975493b58b87605ae5efb7748712b69e652b94a146242df8fbc3ce8cc87 SHA512 b714ac4e743be390dc1484ed29b018da51751f704667cabd8c9c8c7f937eb32863da33f5e7b53838d641e1448e582b9aa729d38df9f25c6eb21358aafd3dbd8c
+DIST nanoc-4.12.21.tar.gz 356922 BLAKE2B 7395bfdba8d27c6f60b8df072bc862c3541beafc4aa36fa5e5e6cce1d558eed462e445fe8414ec952c65840b2eab6cd3457b49a537b8197642bf3bf79074bb71 SHA512 a68af1ef19affe2188a7b4813bda24dd75d6e1c9de4465dd68271c22efb1b7af302906a58465cd177e8dd4922bd3a2292dd3059458e77f8e3e637bf63b3330b7
diff --git a/www-apps/nanoc/nanoc-4.12.21.ebuild b/www-apps/nanoc/nanoc-4.12.21.ebuild
new file mode 100644
index 000000000000..b095445b3524
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.12.21.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="nanoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.app/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/colored-1.2:0
+ >=www-apps/nanoc-checking-1.0.5:1
+ ~www-apps/nanoc-cli-${PV}
+ ~www-apps/nanoc-core-${PV}
+ www-apps/nanoc-deploying:1
+ >=dev-ruby/parallel-1.12:1
+ >=dev-ruby/tty-command-0.8:0
+ >=dev-ruby/tty-which-0.4:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/haml
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/mustache
+ dev-ruby/pry
+ dev-ruby/rdoc
+ >=dev-ruby/rouge-3.5.1:2
+ dev-ruby/rspec-its
+ dev-ruby/rubypants
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+ www-apps/nanoc-spec
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' test/helper.rb ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+ # sed -i -e '2igem "psych", "~> 4.0"' test/helper.rb || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid basepath issues when generating gemspec
+ sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests requiring a network connection or make assumptions
+ # about the local network environment.
+ rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests for unpackaged or obsolete dependencies
+ rm spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{erubis,markaby,rainpress}.rb || die
+
+ # Avoid tests that are specific to haml 6.x which is currently not packaged
+ sed -i -e '/test_filter_\(with_proper_indentation\|error\)/askip "haml 6"' test/filters/test_haml.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -e '124askip "ordering issues"' -e '168askip "ordering issues"' \
+ -i spec/nanoc/data_sources/filesystem_spec.rb || die
+ sed -e '/def test_default_encoding/,/^ end/ s:^:#:' \
+ -i test/orig_cli/commands/test_create_site.rb || die
+
+ # Fix deprecated minitest constant
+ sed -i -e 's/MiniTest/Minitest/' test/rule_dsl/test_rules_collection.rb || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}