summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 18:29:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 18:30:46 +0100
commitf5d8273599568ae47d8e851be882d7030051b565 (patch)
tree2adf91693f6ea85fa51c442b4af0d5e9e175ef6a
parentnet-misc/remmina: properly handle new optional cups dep (diff)
downloadgentoo-f5d82735.tar.gz
gentoo-f5d82735.tar.bz2
gentoo-f5d82735.zip
xfce-extra/xfce4-whiskermenu-plugin: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild8
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.4.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
index 530eae19a64a..bb864569bdf2 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Alternate application launcher for Xfce"
HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
@@ -35,7 +35,7 @@ src_prepare() {
# fix build failure w/ xfce4-panel-4.15.0
sed -i -e 's@<libxfce4panel/xfce-panel-plugin\.h>@<libxfce4panel/libxfce4panel.h>@' \
panel-plugin/register-plugin.c || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -45,7 +45,7 @@ src_configure() {
-DENABLE_DEVELOPER_MODE=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.4.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.4.ebuild
index c4bf5884ef50..203d930b0b47 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.4.ebuild
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Alternate application launcher for Xfce"
HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
@@ -35,7 +35,7 @@ src_prepare() {
# fix build failure w/ xfce4-panel-4.15.0
sed -i -e 's@<libxfce4panel/xfce-panel-plugin\.h>@<libxfce4panel/libxfce4panel.h>@' \
panel-plugin/register-plugin.c || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -45,7 +45,7 @@ src_configure() {
-DENABLE_DEVELOPER_MODE=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {