summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-13 15:22:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-13 15:23:36 +0100
commitf60e0d116e9c9c1aacf5ca604cb38fb68829742b (patch)
treef377982d2228247c44436af98852b553e52b4453
parentsys-kernel/gentoo-sources: Linux 4.14. Patch to support for namespace user.pa... (diff)
downloadgentoo-f60e0d11.tar.gz
gentoo-f60e0d11.tar.bz2
gentoo-f60e0d11.zip
sys-apps/gsmartcontrol: Bump to version 1.1.3
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--sys-apps/gsmartcontrol/Manifest1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
index 215dc8270e45..1e176a0d3186 100644
--- a/sys-apps/gsmartcontrol/Manifest
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -3,3 +3,4 @@ DIST gsmartcontrol-0.9.0.tar.bz2 710515 SHA256 5da6435aa0845acef134f72c2b5f6fce7
DIST gsmartcontrol-1.0.2.tar.bz2 695445 SHA256 4f70451c359d95edc974498b860696b698f19b187340dc7207b4b38cbaf5e207 SHA512 a9dd037fc4223afa762408bc34325fb31947822250efe32ae97b88e836c5bb68d8354d7605925b2ab7c834764ea473a14f2cd1f234577ef76730b02ad9a8b701 WHIRLPOOL 679c6b9fa739f624a1bc523d0c17454cdf69e5899e086044c134116c609aaaf1a4dfec48813bc9b76210b1023623c626a4d9b55bbffa8c603c0340549eb5a028
DIST gsmartcontrol-1.1.0.tar.bz2 683898 SHA256 90c9ead852255f5e1a74a3ff6c265d1cbcba19ad2fc77059c60737c13a3cd2c8 SHA512 c82a7d40a4347ec7c2c5fbd79b8f0035806a54e2dbdbb3fcb8ddba9c92b33a9b737f293b9f959436d0925172c832cca959dfd4a605e19b55aa5cc832c4cee024 WHIRLPOOL 6e22b757fce2cd07ed1133c97c22d8c5d44d0738dcbb342dfd9084b119a92381b5f9ddee2ab904fb576bca0ef5556df6641a8838d3fbc09d6490a8d6f257aeda
DIST gsmartcontrol-1.1.1.tar.bz2 667372 SHA256 2e39ad330829ae93824732f1b663303ac9ea1223f703901fae28549a3b2d7518 SHA512 fc180b85a9db232add4260856e078a578801e11b87df417a5572fab284e992c85009ab9e7d9d6213b2842097067fc119fa0183d5b0dedf8dde71fe4e9e0b38cc WHIRLPOOL f38414b454e0a72904cb1b19a1d10ed6fc7ec3b75422427e1a9f9aaeb6d67946fe773927195af3772ea5320bd613fe984bdecd96313b09a34b0fcd35b3153324
+DIST gsmartcontrol-1.1.3.tar.bz2 677998 SHA256 b64f62cffa4430a90b6d06cd52ebadd5bcf39d548df581e67dfb275a673b12a9 SHA512 7a8bb79875a53d742923fc8ff8336d7fbbdaf2e1b1f64296840557997125d4dcfea9a93a5e8a834003d592083a180ee85ca0e29d3aecf0eb475a3d4fed460456 WHIRLPOOL c8554deb4b7525bc544d654371443c68a82b5b02eab3e002171e40c8b43a21b546f81ddeee7d2130c1d841cde1095d90a1c6a166ed79de018ca3d010f267ce13
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
new file mode 100644
index 000000000000..4757ae7e2385
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="https://gsmartcontrol.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/libpcre:3
+ sys-apps/smartmontools
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )
+"
+
+DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
+
+src_prepare() {
+ default
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }