summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-29 08:01:11 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-29 08:02:57 +0200
commitf61b2c1a08fd0c4b7dc22b88bf091bfa1639b729 (patch)
treed518647cde198d5e7dbd9255dd4c572133e381c1
parentdev-ruby/ruby_parser: add 3.18.0 (diff)
downloadgentoo-f61b2c1a.tar.gz
gentoo-f61b2c1a.tar.bz2
gentoo-f61b2c1a.zip
dev-ruby/ruby-opengl: add ruby30; fix extension install
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..588a4c366535
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/opengl/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=(lib/opengl)
+
+inherit ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="https://github.com/larskanis/opengl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+DEPEND+=" virtual/opengl
+ media-libs/freeglut"
+RDEPEND+=" virtual/opengl
+ media-libs/freeglut"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}