summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-09-09 23:31:00 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-09-09 23:31:00 +0900
commitf62d41215f309cbc3476284fab9d76d560c160f2 (patch)
treec86427fa135954922673d2321c051f542cd52660
parentapp-text/po4a: rename patches (diff)
downloadgentoo-f62d4121.tar.gz
gentoo-f62d4121.tar.bz2
gentoo-f62d4121.zip
app-text/po4a: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/po4a-0.68.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index 7a20586b2204..fc8475b53d58 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1,2 +1,3 @@
DIST po4a-0.66.tar.gz 4240059 BLAKE2B 1d88665b8aa0d7f81854c97265f483934adc51503c2d33252d6ae08a00fddfa8aaa6e9c652f764ae46bf14fea3bcd1093f923fcbf08d96e97296954199e9b900 SHA512 f72e1267cbd6ced01ecc362c327b1634c47dff15398b48644548d28e01ba91108d5626e6d4abcfcb360697e4c0affa3228c6993653ce8f257acbbb3d7ae20fc4
DIST po4a-0.67.tar.gz 4466869 BLAKE2B c4dab0e40e7f5eb24ec85abf8a02131144b181d9b783a5dccc30221d1cc3a493f16d7c2faf8284c6d2f2259661a6f2c280624e5fd16e2d4d0bf878f8291ef7b5 SHA512 6445db615ac1a2e752daca7dca0c44a88e74c7a26c06ba8e7cb6bdeeaacce78cb74a671579dd95ee8341d817e16717e8cf99022a37c5d152e0c9828bd6aae3d9
+DIST po4a-0.68.tar.gz 4605485 BLAKE2B fe649a28c0c181f53d7eb3f583d4a7dffe4fc22fb316c1c534b672a267eef16ccdf39a77caff3a2d75b7bfcb36e68c49229aaddeb8dff5ee475b71b58402200e SHA512 d7c60a3647d8f4265ce6f016d33430c72775ae19eb2efb240532545b08280368fea70db3360131f6537eb7cc72c19299dff4b6f938ac09cbef1b2db1a93d996e
diff --git a/app-text/po4a/po4a-0.68.ebuild b/app-text/po4a/po4a-0.68.ebuild
new file mode 100644
index 000000000000..300d739e1730
--- /dev/null
+++ b/app-text/po4a/po4a-0.68.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="ace af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK zh_Hant"
+
+inherit perl-module plocale
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/Pod-Parser
+ dev-perl/SGMLSpm
+ dev-perl/Syntax-Keyword-Try
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ sys-devel/gettext
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
+DIST_TEST="do"
+
+src_prepare() {
+ plocale_find_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ plocale_for_each_disabled_locale rm_locale
+
+ perl-module_src_prepare
+}