summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2022-11-27 20:05:52 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-29 06:59:07 -0800
commitf62d7c6599bbb275f7863bd1fef0f5d31a673703 (patch)
treed92919c0b08650b7db614601419acc700ee5444f
parentdev-util/cargo-c: Bump os_str_bits to 6.4.1 (diff)
downloadgentoo-f62d7c65.tar.gz
gentoo-f62d7c65.tar.bz2
gentoo-f62d7c65.zip
net-im/telegram-desktop: Bump to 4.3.4
Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.3.4-fix-disabling-spellcheck.patch43
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-1.patch42
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-2.patch28
-rw-r--r--net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild206
5 files changed, 320 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index fd5e85fb3f0d..b7e61178b0e8 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,3 +1,4 @@
DIST tdesktop-3.6.1-full.tar.gz 41226549 BLAKE2B 6922ae015e36f86597aaedf1212ed951d6313a8f5f76a8838ab7ef9e02afe0cbc428acd991488190bafdf28faf2a69a09a5a1e963b2aa6ed27ef941602e15d88 SHA512 dd216c720ea3b1c72669805bb31319746a7ddfe746d188bf2ae0c5cdf0a10b379fc2e888a26fe755d77381fc5d9aa638cedc76b2dce1f1126a9c1ef9c02da2ba
DIST tdesktop-4.2.4-full.tar.gz 49210806 BLAKE2B 5900f977156f8ec98098a5e2fe97efcc5c2d7e2768123268e4b232e384c47a02fec11b3d5d875f99134aace9d3d7f937defb83ea1572d41c7df52f4d1bda1e9c SHA512 c0b458e4f21855d1041f7343ffdd501890a7535d040b45a8bd565e545d5bc01a00703af65e14ae407bf53f81a6d28d3f7d6afa664eb5b8e5641b21bb8e669a3a
DIST tdesktop-4.3.1-full.tar.gz 49305237 BLAKE2B 3f0605adb6b471ecd913921a836c8d0e09d5fb40f107290d085af2a0ad64f7f067014b381a50317ffa089ce68724629972c565619d4d24776ac3496c15d9959f SHA512 365c16f4260827e3ad7e066f6ec96fc97a6f5874df376933f16de20c3488c24f52bc1aa3bd5df936f29a198e287dc8e706b259d57d7d7a9d6468c7edc7568514
+DIST tdesktop-4.3.4-full.tar.gz 50030732 BLAKE2B 68d9001128cca6e8a68d991e77a20f9764af9a634c37d792e92f7e77b0446b6d16ec1342f9e7ce7e0c49464f385f795164f9d176d65a74fc64fc072eae33d263 SHA512 415e0d60508317ef6d07e1f8aa2d974b166925f19349106cc543e487dd5bef8d1ff0548fb815682c6c4bb3bf762c08fcb1c7073f2c7ad305ae885b7979c70f88
diff --git a/net-im/telegram-desktop/files/tdesktop-4.3.4-fix-disabling-spellcheck.patch b/net-im/telegram-desktop/files/tdesktop-4.3.4-fix-disabling-spellcheck.patch
new file mode 100644
index 000000000000..9529370cdbae
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-4.3.4-fix-disabling-spellcheck.patch
@@ -0,0 +1,43 @@
+Fix building without spellcheck
+
+Upcoming changes to tdesktop include language recognition, which is a bit of a
+doozy, and as is tradition, "unusual" compilation flags go untested.
+
+Regular builds would always return false here, anyway, as linux isn't a
+priority with these things.
+
+/var/tmp/portage/net-im/telegram-desktop-4.3.4/work/tdesktop-4.3.4-full/Telegram/SourceFiles/boxes/translate_box.cpp:18:10: fatal error: spellcheck/platform/platform_language.h: No such file or directory
+ 18 | #include "spellcheck/platform/platform_language.h"
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+compilation terminated.
+
+--- tdesktop-4.3.4-full.orig/Telegram/SourceFiles/boxes/translate_box.cpp
++++ tdesktop-4.3.4-full/Telegram/SourceFiles/boxes/translate_box.cpp
+@@ -15,7 +15,9 @@
+ #include "main/main_session.h"
+ #include "mtproto/sender.h"
+ #include "settings/settings_common.h"
++#ifndef TDESKTOP_DISABLE_SPELLCHECK
+ #include "spellcheck/platform/platform_language.h"
++#endif
+ #include "ui/effects/loading_element.h"
+ #include "ui/layers/generic_box.h"
+ #include "ui/widgets/buttons.h"
+@@ -331,6 +333,7 @@
+ if (!hasLetters) {
+ return true;
+ }
++#ifndef TDESKTOP_DISABLE_SPELLCHECK
+ const auto result = Platform::Language::Recognize(text);
+ if (result.unknown) {
+ return false;
+@@ -343,6 +346,9 @@
+ ? QLocale::English
+ : settingsLang;
+ return (result.locale.language() == skip);
++#else
++ return false;
++#endif
+ }
+
+ } // namespace Ui
diff --git a/net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-1.patch b/net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-1.patch
new file mode 100644
index 000000000000..3229b5be54c8
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-1.patch
@@ -0,0 +1,42 @@
+Disable portal-related event loop with qt5
+
+QEventLoop::ApplicationExec is undocumented, but only present in qt6, so I have
+no idea if the functionality can be preserved in qt5. Upstream code indicates
+that not using it at all is safe, and unlikely to cause problems in
+distribution packaging.
+
+Yet another reminder that qt5 is dying.
+
+/var/tmp/portage/net-im/telegram-desktop-4.3.4/work/tdesktop-4.3.4-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp: In lambda function:
+/var/tmp/portage/net-im/telegram-desktop-4.3.4/work/tdesktop-4.3.4-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp:294:55: error: ‘ApplicationExec’ is not a member of ‘QEventLoop’
+ 294 | loop.exec(QEventLoop::ApplicationExec);
+ | ^~~~~~~~~~~~~~~
+
+--- tdesktop-4.3.4-full.orig/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ tdesktop-4.3.4-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -229,6 +229,7 @@
+ }
+ }
+
++#if QT_VERSION >= QT_VERSION_CHECK(6, 2, 0)
+ void LaunchGApplication() {
+ const auto connection = [] {
+ try {
+@@ -401,6 +402,7 @@
+ });
+ }
+ }
++#endif // QT_VERSION >= QT_VERSION_CHECK(6, 2, 0)
+
+ bool GenerateDesktopFile(
+ const QString &targetPath,
+@@ -862,7 +864,9 @@
+ LOG(("Fallback icon theme: %1").arg(QIcon::fallbackThemeName()));
+
+ #ifndef DESKTOP_APP_DISABLE_DBUS_INTEGRATION
++#if QT_VERSION >= QT_VERSION_CHECK(6, 2, 0)
+ LaunchGApplication();
++#endif // QT_VERSION >= QT_VERSION_CHECK(6, 2, 0)
+ #endif // !DESKTOP_APP_DISABLE_DBUS_INTEGRATION
+ }
+
diff --git a/net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-2.patch b/net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-2.patch
new file mode 100644
index 000000000000..ae5c84763c8d
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-4.3.4-qt5-incompatibility-2.patch
@@ -0,0 +1,28 @@
+Disable unused incompatible overload with qt5
+
+Neither Qt nore C++ are my forte, but this code is unused with the packaged
+distro version, anyway.
+
+/var/tmp/portage/net-im/telegram-desktop-4.3.4/work/tdesktop-4.3.4-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp: In lambda function:
+/var/tmp/portage/net-im/telegram-desktop-4.3.4/work/tdesktop-4.3.4-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp:705:74: error: call of overloaded ‘arg(QByteArray&)’ is ambiguous
+ 705 | return qsl("org.telegram.desktop.%1.desktop").arg(md5Hash);
+ | ^
+
+--- tdesktop-4.3.4-full.orig/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ tdesktop-4.3.4-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -692,6 +692,7 @@
+ + qsl(".desktop");
+ }
+
++#if !(defined(TDESKTOP_DISABLE_AUTOUPDATE) && QT_VERSION < QT_VERSION_CHECK(6, 2, 0))
+ if (!Core::UpdaterDisabled()) {
+ QByteArray md5Hash(h);
+ if (!Launcher::Instance().customWorkingDir()) {
+@@ -706,6 +707,7 @@
+
+ return qsl("org.telegram.desktop.%1.desktop").arg(md5Hash);
+ }
++#endif // !(defined(TDESKTOP_DISABLE_AUTOUPDATE) && QT_VERSION < QT_VERSION_CHECK(6, 2, 0))
+
+ return qsl("org.telegram.desktop.desktop");
+ }());
diff --git a/net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild b/net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild
new file mode 100644
index 000000000000..2f1d55aaabb3
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild
@@ -0,0 +1,206 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit xdg cmake python-any-r1 optfeature
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+IUSE="+dbus enchant +fonts +hunspell +jemalloc screencast +spell qt6 qt6-imageformats wayland +X"
+REQUIRED_USE="
+ spell? (
+ ^^ ( enchant hunspell )
+ )
+ qt6-imageformats? ( qt6 )
+"
+
+KIMAGEFORMATS_RDEPEND="
+ media-libs/libavif:=
+ media-libs/libheif:=
+ media-libs/libjxl
+"
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/abseil-cpp:=
+ dev-libs/glib:2
+ dev-libs/libdispatch
+ dev-libs/libsigc++:2
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig:=
+ media-libs/libjpeg-turbo:=
+ ~media-libs/libtgvoip-2.4.4_p20220503
+ media-libs/openal
+ media-libs/opus:=
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20220507:=[screencast=,X=]
+ media-video/ffmpeg:=[opus]
+ sys-libs/zlib:=[minizip]
+ x11-libs/xcb-util-keysyms
+ virtual/opengl
+ dbus? ( dev-cpp/glibmm:2.68 )
+ enchant? ( app-text/enchant:= )
+ hunspell? ( >=app-text/hunspell-1.7:= )
+ jemalloc? ( dev-libs/jemalloc:=[-lazy-lock] )
+ !qt6? (
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5[dbus?,jpeg,png,wayland?,X?]
+ >=dev-qt/qtimageformats-5.15:5
+ >=dev-qt/qtnetwork-5.15:5[ssl]
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5[png,X?]
+ kde-frameworks/kcoreaddons:=
+ )
+ qt6? (
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[dbus?,gui,network,opengl,widgets,X?]
+ dev-qt/qtimageformats:6
+ dev-qt/qtsvg:6
+ wayland? ( dev-qt/qtwayland:6 )
+ qt6-imageformats? ( ${KIMAGEFORMATS_RDEPEND} )
+ )
+ X? ( x11-libs/libxcb:= )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/range-v3
+ =dev-cpp/ms-gsl-3*
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+"
+# dev-libs/jemalloc:=[-lazy-lock] -> https://bugs.gentoo.org/803233
+
+PATCHES=(
+ "${FILESDIR}/tdesktop-4.2.4-jemalloc-only-telegram.patch"
+ "${FILESDIR}/tdesktop-3.3.0-fix-enchant.patch"
+ "${FILESDIR}/tdesktop-4.3.4-fix-disabling-spellcheck.patch"
+ "${FILESDIR}/tdesktop-4.3.4-qt5-incompatibility-1.patch"
+ "${FILESDIR}/tdesktop-4.3.4-qt5-incompatibility-2.patch"
+)
+
+# Current desktop-file-utils-0.26 does not understand Version=1.5
+QA_DESKTOP_FILE="usr/share/applications/${PN}.desktop"
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # Bundle kde-frameworks/kimageformats for qt6, since it's impossible to
+ # build in gentoo right now.
+ if use qt6-imageformats; then
+ sed -e 's/DESKTOP_APP_USE_PACKAGED_LAZY/TRUE/' -i \
+ cmake/external/kimageformats/CMakeLists.txt || die
+ printf "%s\n" \
+ 'Q_IMPORT_PLUGIN(QAVIFPlugin)' \
+ 'Q_IMPORT_PLUGIN(HEIFPlugin)' \
+ 'Q_IMPORT_PLUGIN(QJpegXLPlugin)' \
+ >> cmake/external/qt/qt_static_plugins/qt_static_plugins.cpp || die
+ fi
+
+ # kde-frameworks/kcoreaddons is bundled when using qt6, see:
+ # cmake/external/kcoreaddons/CMakeLists.txt
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
+ -DQT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION=$(usex !dbus)
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex !X)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex !wayland)
+ -DDESKTOP_APP_DISABLE_JEMALLOC=$(usex !jemalloc)
+ -DDESKTOP_APP_DISABLE_SPELLCHECK=$(usex !spell) # enables hunspell (recommended)
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant) # enables enchant and disables hunspell
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=$(usex !fonts) # use system fonts instead of bundled ones
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! use X && ! use screencast; then
+ ewarn "both the 'X' and 'screencast' USE flags are disabled, screen sharing won't work!"
+ ewarn
+ fi
+ if has_version '<dev-qt/qtcore-5.15.2-r10'; then
+ ewarn "Versions of dev-qt/qtcore lower than 5.15.2-r10 might cause telegram"
+ ewarn "to crash when pasting big images from the clipboard."
+ ewarn
+ fi
+ if ! use jemalloc && use elibc_glibc; then
+ # https://github.com/telegramdesktop/tdesktop/issues/16084
+ # https://github.com/desktop-app/cmake_helpers/pull/91#issuecomment-881788003
+ ewarn "Disabling USE=jemalloc on glibc systems may cause very high RAM usage!"
+ ewarn "Do NOT report issues about RAM usage without enabling this flag first."
+ ewarn
+ fi
+ if use qt6; then
+ ewarn "Qt6 support in gentoo is experimental."
+ ewarn "Please report any issues you may find, but don't expect"
+ ewarn "everything to work correctly as of yet."
+ ewarn
+ fi
+ if use wayland && ! use qt6; then
+ ewarn "Wayland-specific integrations have been deprecated with Qt5."
+ ewarn "The app will continue to function under wayland, but some"
+ ewarn "functionality may be reduced."
+ ewarn "These integrations are only supported when built with Qt6."
+ ewarn
+ fi
+ if use qt6 && ! use qt6-imageformats; then
+ elog "Enable USE=qt6-imageformats for AVIF, HEIF and JpegXL support"
+ elog
+ fi
+ optfeature_header
+ optfeature "shop payment support (requires USE=dbus enabled)" net-libs/webkit-gtk:4
+ if ! use qt6; then
+ optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats[avif,heif,jpegxl]
+ fi
+}