summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-11 08:36:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-11 09:04:33 +0100
commitf659178ebd003ce4dbe3711fe1114eee2b9bc615 (patch)
treef1d86c608569716ac2a86b79794f567bdf2311ab
parentpackage.mask: Recover dev-python/{cssselect2,tinycss2} (diff)
downloadgentoo-f659178ebd003ce4dbe3711fe1114eee2b9bc615.tar.gz
gentoo-f659178ebd003ce4dbe3711fe1114eee2b9bc615.tar.bz2
gentoo-f659178ebd003ce4dbe3711fe1114eee2b9bc615.zip
dev-python/tinycss2: Unjunk, py3.{7,8}
Closes: https://bugs.gentoo.org/697500 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tinycss2/tinycss2-1.0.2.ebuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/dev-python/tinycss2/tinycss2-1.0.2.ebuild b/dev-python/tinycss2/tinycss2-1.0.2.ebuild
index dbf0755a9525..9e198b9259ec 100644
--- a/dev-python/tinycss2/tinycss2-1.0.2.ebuild
+++ b/dev-python/tinycss2/tinycss2-1.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -14,23 +14,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/webencodings-0.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-flake8[${PYTHON_USEDEP}]
- dev-python/pytest-isort[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( README.rst )
-
-python_test() {
- py.test || die "testsuite failed under ${EPYTHON}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # junk deps
+ sed -i -e '/pytest-runner/d' -e '/^addopts/d' setup.cfg || die
+ distutils-r1_src_prepare
}