summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-29 12:50:19 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-29 12:50:37 -0400
commitf65f4a79170e0507509d75c170c3ec530854e825 (patch)
tree39d7bffce2d59c29cf07b766dcc436cea598bb3a
parentnet-libs/libssh: Stabilize 0.10.4 hppa, #873439 (diff)
downloadgentoo-f65f4a79.tar.gz
gentoo-f65f4a79.tar.bz2
gentoo-f65f4a79.zip
x11-libs/libva-intel-media-driver: Version bump to 22.5.3.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libva-intel-media-driver/Manifest1
-rw-r--r--x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.5.3.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/libva-intel-media-driver/Manifest b/x11-libs/libva-intel-media-driver/Manifest
index 941c53ea5379..03b65dc3d778 100644
--- a/x11-libs/libva-intel-media-driver/Manifest
+++ b/x11-libs/libva-intel-media-driver/Manifest
@@ -1,2 +1,3 @@
DIST intel-media-22.4.4.tar.gz 27437439 BLAKE2B 63bee317ff12c34e7a2da9f5dce51ebb21708f8b5b3f3a58618f487e72f7826f0d4afa486bac08c2db8582d8a4774de716b5bb9a3dff93ff4fc266e56d434519 SHA512 e6ed669476e42396df7714732c628aa67d90fc8040c006605b754d70bdb7ecf476c5eb5c849a8647646dd3858c5fd469ba05f5c6b02b36d2211dc4f4cc7fa77f
+DIST intel-media-22.5.3.1.tar.gz 27492012 BLAKE2B e300eba764dde8f2d6c07f4768bca253a21ae5f3bcfd829257541fb26c8a997390011a8bfdfab964eafe37fcece5db4826700bccda672ef51b2f62de2ea94d17 SHA512 aab70004aa3bd91ced7b147e4cd4bd662fe0813b2deeaa90e61f4d692d43a302a1e18dad502bbedb5102593f21f9710a56e202f0ba70a58afed139df3bf2bb78
DIST intel-media-22.5.3.tar.gz 27488655 BLAKE2B 90d79ac8e7ab8cb97941d37fe81ce4524cef45e49e4b64e57931f00927cb2065c0b6f8b4fff5aba58cb9ea64548337261e37df13a53ba07c8ab81db160990e6e SHA512 987ca85ed95272945fd8c23a388ca68481ff5fdf74737a04659304e58c6d131c00db03ee134fc3549225a9fc33b874632335f1182d1e0c6d90fbc5ea290b486d
diff --git a/x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.5.3.1.ebuild b/x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.5.3.1.ebuild
new file mode 100644
index 000000000000..afd945b8dab0
--- /dev/null
+++ b/x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.5.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/media-driver"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ MY_PV="${PV%_pre}"
+ SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz"
+ S="${WORKDIR}/media-driver-intel-media-${MY_PV}"
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~amd64"
+ fi
+fi
+
+DESCRIPTION="Intel Media Driver for VA-API (iHD)"
+HOMEPAGE="https://github.com/intel/media-driver"
+
+LICENSE="MIT BSD redistributable? ( no-source-code )"
+SLOT="0"
+IUSE="+redistributable test X"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=media-libs/gmmlib-22.0.0:=
+ >=x11-libs/libva-2.14.0[X?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-21.4.2-Remove-unwanted-CFLAGS.patch
+ "${FILESDIR}"/${PN}-20.4.5_testing_in_src_test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEDIA_BUILD_FATAL_WARNINGS=OFF
+ -DMEDIA_RUN_TEST_SUITE=$(usex test)
+ -DBUILD_TYPE=Release
+ -DPLATFORM=linux
+ -DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X)
+ -DENABLE_NONFREE_KERNELS=$(usex redistributable)
+ -DLATEST_CPP_NEEDED=ON # Seems to be the best option for now
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}