summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-08-01 12:29:41 +0200
committerHanno <hanno@gentoo.org>2019-08-01 12:29:41 +0200
commitf66ff3b450f05eedc5966d6d7a3484776f172b33 (patch)
tree78fc6ac3ca5c2738dd875e001e87d4d71111ce33
parentnet-fs/minio: Version bump (diff)
downloadgentoo-f66ff3b4.tar.gz
gentoo-f66ff3b4.tar.bz2
gentoo-f66ff3b4.zip
dev-python/python-recaptcha: Allow pycryptodome, EAPI 7.
Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.69, Repoman-2.3.16
-rw-r--r--dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..ab63a2563b07
--- /dev/null
+++ b/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="|| ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"