summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-10-24 11:24:33 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-10-24 11:24:57 +0200
commitf6738965cc0ee32882cfe767d74b8f2a1a89ea37 (patch)
treea3f3d8a5782b0fdc0b4c79e61b0f37a6e91a6885
parentx11-misc/picom: drop old (diff)
downloadgentoo-f6738965.tar.gz
gentoo-f6738965.tar.bz2
gentoo-f6738965.zip
x11-misc/picom: 8.2 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-misc/picom/Manifest1
-rw-r--r--x11-misc/picom/picom-8.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/picom/Manifest b/x11-misc/picom/Manifest
index df2265e2a535..a43ba54a5085 100644
--- a/x11-misc/picom/Manifest
+++ b/x11-misc/picom/Manifest
@@ -1,2 +1,3 @@
DIST picom-8.1.tar.gz 242262 BLAKE2B 69583a7a188f62387f0784e33acfc3d84e6b7b1987f44f7634b1bd2244ae8e8763c2131a824f8ddd748558002a876cb359c656a93fcb55ad33a24cca2b7dc56e SHA512 d1d0428e5761db6820c775c07b966b5fec6a9e9d049ba9f555eb49721f855a018df7242ef61e29c0ea003644b20e1bb733ddf668053a8d4040240e98707fa4d3
+DIST picom-8.2.tar.gz 242653 BLAKE2B 1c76ad4b3152d47155f957f8f1e75447ec8e30d05bc5fb9bf09c890552168cc3c607c8980b262b18cd5f3dc2654a3416cad20cb7fe829eaef8380783d1847c82 SHA512 bdc6675e73a211075ee0df2b056342cabb19ad27fd73586f5216886f503cd994536845eb866f371e07a8dc0404346c67b899a14830e9b7cbc9c01cbd782f36b1
DIST picom-8.tar.gz 242059 BLAKE2B cfeec7f40eaa43c115bd326abeaa547553f7bdd22a2e6b2a96f46d87c164b0e9403a876f069077e3b85d11af685aadb0cff2a4e7df2cf87646f2552f9c1a01df SHA512 154dd42dea16aca463e7d7f9913a8f10740df892bfdda2fee210a94b13c8eaf6201b35e505daf45075fdb1980bb9b85adf170b649702c1b1e2fcdc1d88406b4a
diff --git a/x11-misc/picom/picom-8.2.ebuild b/x11-misc/picom/picom-8.2.ebuild
new file mode 100644
index 000000000000..993b85a8ab0f
--- /dev/null
+++ b/x11-misc/picom/picom-8.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="
+ dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig
+ dev-libs/libxdg-basedir
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}