summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-02 20:02:28 +0000
committerSam James <sam@gentoo.org>2023-01-02 20:03:00 +0000
commitf67cb41cea030242bb1193cd4b6dc3abb4335fd9 (patch)
tree23c32b9312d40da6e454e3c3dc9e273260cafc88
parentdev-vcs/python-gitlab: pkgcheck fixes (diff)
downloadgentoo-f67cb41c.tar.gz
gentoo-f67cb41c.tar.bz2
gentoo-f67cb41c.zip
dev-python/pytest-cov: enable py3.11
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch21
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild8
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch b/dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch
new file mode 100644
index 000000000000..6ed3456597cf
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-4.0.0-pytest-xdist-2.5.0.patch
@@ -0,0 +1,21 @@
+https://github.com/pytest-dev/pytest-cov/issues/566
+https://github.com/pytest-dev/pytest-cov/pull/565
+
+From 97483386bde4febe7ff48726f887cc6423d308b9 Mon Sep 17 00:00:00 2001
+From: Chedi <chedi.toueiti@gmail.com>
+Date: Tue, 15 Nov 2022 11:18:31 +0100
+Subject: [PATCH] disabling boxed test if version xdist newer than 2.5.0
+
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -1555,7 +1555,8 @@ def test_foo():
+
+ SCRIPT_SIMPLE_RESULT = '4 * 100%'
+
+-
++@pytest.mark.skipif('tuple(map(int, xdist.__version__.split("."))) >= (2, 5, 0)',
++ reason="--boxed option was removed in version 2.5.0")
+ @pytest.mark.skipif('sys.platform == "win32"')
+ def test_dist_boxed(testdir):
+ script = testdir.makepyfile(SCRIPT_SIMPLE)
+
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
index 61bbc23db863..50a1d98287f1 100644
--- a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -33,6 +33,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
+)
+
distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme
distutils_enable_tests pytest