summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-08-14 15:23:33 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-08-14 15:26:59 -0500
commitf67faee656398651831a653abb3774e8655aa08a (patch)
tree40a607c88b347ee16092f7d57fb125fed6367a7e
parentsys-fs/go-mtpfs: 1.0.0 bump (diff)
downloadgentoo-f67faee6.tar.gz
gentoo-f67faee6.tar.bz2
gentoo-f67faee6.zip
sys-fs/go-mtpfs: remove old live ebuild
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-fs/go-mtpfs/go-mtpfs-9999.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
deleted file mode 100644
index e197761b32ae..000000000000
--- a/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit git-r3 flag-o-matic toolchain-funcs
-
-DESCRIPTION="a simple FUSE filesystem for mounting Android devices as a MTP device"
-HOMEPAGE="https://github.com/hanwen/go-mtpfs"
-EGIT_REPO_URI="https://github.com/hanwen/go-mtpfs.git"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-COMMON_DEPEND="virtual/libusb:1
- virtual/udev"
-DEPEND="${COMMON_DEPEND}
- dev-libs/go-fuse
- dev-libs/go-usb
- dev-lang/go
- media-libs/libmtp"
-
-RDEPEND="${COMMON_DEPEND}"
-
-#Tests require a connected mtp device
-RESTRICT="test"
-
-GO_PN="github.com/hanwen/${PN}"
-EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
-QA_FLAGS_IGNORED=usr/bin/go-mtpfs
-
-export GOPATH="${S}"
-
-src_compile() {
- go build -ldflags '-extldflags=-fno-PIC' -v -x -work ${GO_PN} || die
-}
-
-src_test() {
- go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/fs || die
- go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/usb || die
- go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/mtp || die
-}
-
-src_install() {
- dobin go-mtpfs
-}