summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-26 06:45:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-26 06:45:25 +0100
commitf682d66bc6efeaf340228ccabf1058e7bfda31d3 (patch)
treef3fb1193f5123628f3592fd735c6280c3730a405
parentdev-python/pytest-check: Bump to 1.2.0 (diff)
downloadgentoo-f682d66bc6efeaf340228ccabf1058e7bfda31d3.tar.gz
gentoo-f682d66bc6efeaf340228ccabf1058e7bfda31d3.tar.bz2
gentoo-f682d66bc6efeaf340228ccabf1058e7bfda31d3.zip
dev-python/zipp: Bump to 3.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.11.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 3e2876177554..0bbebe67ece8 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.10.0.tar.gz 15564 BLAKE2B 145374d6e2e251f588e198a0fd400542b34ff26de4e1240dd30710dc33e884ccde91ca1cc168d5f421aa4e04341c76cfb10fbf176c830ade237be39a886267ab SHA512 2e64b05eb0123eb3c3c87fbfe2da26721eb9e24142a43e794d04e5f86ab5fe4cf3e0e3e3497bfc9631ab61dd64226829772493f26e091a66148ddbdc5dfd8e51
+DIST zipp-3.11.0.tar.gz 16799 BLAKE2B 96cbb86e4c112a2cc0bbd8cf8f7a6d0e7b5a5b4af0857bfea87583341e7d08c9f0879f8455131f81e21ffb75bb362fb312c5575a8ccb2e2996313fe3f95ffe36 SHA512 10e1eca131063d9e34db18320152ea5e2445585802e7814fcb0a0aeddd8eb5481c60c2eaca1f7f2729826aafd4004fc4a0b8ee26896c833f789752a501f77e86
diff --git a/dev-python/zipp/zipp-3.11.0.ebuild b/dev-python/zipp/zipp-3.11.0.ebuild
new file mode 100644
index 000000000000..0604a8099e8a
--- /dev/null
+++ b/dev-python/zipp/zipp-3.11.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ tests/test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+src_prepare() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' tests/test_zipp.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}