summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-07 09:09:49 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-07 09:09:49 +0100
commitf6908ce85e83318004b89909d766e4e743147a63 (patch)
tree050905704846baad1038f770a92e9ae663d21f2b
parentdev-ruby/hashie: clean masked slot (diff)
downloadgentoo-f6908ce8.tar.gz
gentoo-f6908ce8.tar.bz2
gentoo-f6908ce8.zip
dev-ruby/thor: clean masked slot
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-0.20.3-r1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index 91dc158b6022..0a5b9f391cf4 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1,2 +1 @@
-DIST thor-git-0.20.3.tgz 94786 BLAKE2B a27ef27d9d375c1f5ab1b065f6ee5b635dab3b43cac7915ae24771e7a9e24189b8c3df8936bf6ad333f0660e4e36ff73372746afc227972f1745dc993b90c85f SHA512 368cedd9584fcdecf8f5feb9b727aa283b37747e8200f8629aaa762f8e3a59dafe6ee1e7c60ef2b43b2a16b319842b10d0f3face12ba8dded4b6211640db7f44
DIST thor-git-1.1.0.tgz 98252 BLAKE2B 1537cfe6e7cc0d92cc8bde56f0e2acf06b6ee4cb366a5686bb62de43dd15709a4aeaf1b30c3dfa71a6d6c7570e702deeebab6da324204388ac427337514be3f0 SHA512 d1872a834478c5a2054dde6f55e93f6765fd628536f99f888bd7495436c88658537d48c44ef1e5ad6d1388edfa294ea2a3f3cbde32c19b7d2253b78bc62bf9d0
diff --git a/dev-ruby/thor/thor-0.20.3-r1.ebuild b/dev-ruby/thor/thor-0.20.3-r1.ebuild
deleted file mode 100644
index 2d5e5d26fd83..000000000000
--- a/dev-ruby/thor/thor-0.20.3-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="doc"
-
-USE_RUBY="ruby23 ruby24 ruby25" ruby_add_bdepend "
- test? (
- dev-ruby/childlabor
- dev-ruby/webmock
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby27)
- einfo "Skipping tests due to circular dependencies"
- ;;
- *)
- RSPEC_VERSION=3 ruby-ng_rspec spec || die
- ;;
- esac
-}