summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-02 07:06:36 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-02 07:09:04 -0400
commitf6bc01c6dc39ae282df30c969c06e39b5751db32 (patch)
treea723e5ad76e95bfb31dc3896affeb238e3c9868d
parentdev-python/pyopencl: drop 2022.1.5 (diff)
downloadgentoo-f6bc01c6.tar.gz
gentoo-f6bc01c6.tar.bz2
gentoo-f6bc01c6.zip
sci-libs/givaro: fix pkg-config libdir, update EAPI 7 -> 8
Apply François Bissey's upstream patch in a new revision. Closes: https://bugs.gentoo.org/862753 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-libs/givaro/files/givaro-4.1.1-fix-pc-libdir.patch21
-rw-r--r--sci-libs/givaro/givaro-4.1.1-r3.ebuild59
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-libs/givaro/files/givaro-4.1.1-fix-pc-libdir.patch b/sci-libs/givaro/files/givaro-4.1.1-fix-pc-libdir.patch
new file mode 100644
index 000000000000..35a536c04ad8
--- /dev/null
+++ b/sci-libs/givaro/files/givaro-4.1.1-fix-pc-libdir.patch
@@ -0,0 +1,21 @@
+From f5cbcebd7fcc2b68d6e1e9f1ba3aa53b9ed17b56 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fran=C3=A7ois=20Bissey?= <frp.bissey@gmail.com>
+Date: Sun, 7 Aug 2022 13:25:24 +1200
+Subject: [PATCH] Fix givaro.pc.in file for issue #200
+
+---
+ givaro.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/givaro.pc.in b/givaro.pc.in
+index a4805555..9487ef8c 100644
+--- a/givaro.pc.in
++++ b/givaro.pc.in
+@@ -1,6 +1,6 @@
+ prefix=@prefix@
+ exec_prefix=@prefix@
+-libdir=@prefix@/lib
++libdir=@libdir@
+ includedir=@prefix@/include
+
+ Name: Givaro
diff --git a/sci-libs/givaro/givaro-4.1.1-r3.ebuild b/sci-libs/givaro/givaro-4.1.1-r3.ebuild
new file mode 100644
index 000000000000..f1ac1cd50f83
--- /dev/null
+++ b/sci-libs/givaro/givaro-4.1.1-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="C++ library for arithmetic and algebraic computations"
+HOMEPAGE="https://casys.gricad-pages.univ-grenoble-alpes.fr/givaro/"
+SRC_URI="https://github.com/linbox-team/givaro/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="CeCILL-B"
+SLOT="0/9"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 doc static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+DEPEND="dev-libs/gmp:0[cxx(+)]"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+PATCHES=(
+ "${FILESDIR}/givaro-4.1.1-gcc-10.patch"
+ "${FILESDIR}/givaro-4.1.1-fix-pc-libdir.patch"
+)
+
+src_configure() {
+ # Passing "--disable-doc" also accidentally enables building
+ # the documentation, so we can't just $(use_enable doc) here.
+ # https://github.com/linbox-team/givaro/issues/148
+ econf \
+ $(usex doc --enable-doc "" "" "") \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_fma3 fma) \
+ $(use_enable cpu_flags_x86_fma4 fma4) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_sse4_2 sse42) \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable cpu_flags_x86_avx2 avx2)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}