summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-25 07:32:30 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-25 07:32:30 +0100
commitf6ead0f5fe87a309ad8e398761380996ddab9135 (patch)
treec87e01068b018379312782bbb8a49fd2a08f2e6a
parentx11-wm/i3: add 4.22 (diff)
downloadgentoo-f6ead0f5.tar.gz
gentoo-f6ead0f5.tar.bz2
gentoo-f6ead0f5.zip
dev-embedded/u-boot-tools: drop 2022.07
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index b73e288f4f19..8972701796ea 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -1,2 +1 @@
-DIST u-boot-2022.07.tar.bz2 18087759 BLAKE2B bb78c7ccd56f12ebc622fb73d29cbf0a5db9d421133b191a6591845b4842b111145d2df649bae69011284bd468b8219ee0df20b61660ea4ec52006a93e14f09d SHA512 e1b3621dafac876c644ffb3d24b6e2380f5a78454c420a5b17d174e3f0b57731a95cfbff28ae7d0af4493f4bbf8d21e7f9236d61bb2414ed12295332b3d557b6
DIST u-boot-2022.10.tar.bz2 18365430 BLAKE2B 42aa7a6f131735888939982e579de4342e3909e064ab896b0df6f1ff56c20ed6cb11d25286da7c052a5f67dcef6fa7a746944d8df6dd504586f5a71502d157e1 SHA512 95bc1f915a3349f6045e59f46d8514485ca0de1d62303f7026b8e59f3ac539b9545895e0dd736ed7b26f28239db31672ecad2accc3fd99356a55269697039147
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild
deleted file mode 100644
index 5c8bda198ccf..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_P="u-boot-${PV/_/-}"
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="https://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
-IUSE="envtools"
-
-RDEPEND="dev-libs/openssl:="
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-lang/swig
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
- scripts/kconfig/{g,m,n,q}conf-cfg.sh \
- scripts/kconfig/Makefile \
- tools/Makefile || die
-}
-
-src_configure() {
- tc-export AR BUILD_CC CC PKG_CONFIG
- tc-export_build_env
-}
-
-src_compile() {
- # Unset a few KBUILD variables. Bug #540476
- unset KBUILD_OUTPUT KBUILD_SRC
-
- local myemakeargs=(
- V=1
- AR="${AR}"
- CC="${CC}"
- HOSTCC="${BUILD_CC}"
- HOSTCFLAGS="${BUILD_CFLAGS} ${BUILD_CPPFLAGS}"' $(HOSTCPPFLAGS)'
- HOSTLDFLAGS="${BUILD_LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}" tools-only_defconfig
-
- emake "${myemakeargs[@]}" \
- NO_SDL=1 \
- HOSTSTRIP=: \
- STRIP=: \
- CONFIG_ENV_OVERWRITE=y \
- $(usex envtools envtools tools-all)
-}
-
-src_test() { :; }
-
-src_install() {
- cd tools || die
-
- if ! use envtools; then
- dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
- fi
-
- dobin env/fw_printenv
-
- dosym fw_printenv /usr/bin/fw_setenv
-
- insinto /etc
- doins env/fw_env.config
-
- doman ../doc/mkimage.1
-}