summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-02 08:55:36 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-02 08:55:36 +0200
commitf6f304336d036d81d199cd4be4a9975ec9840d5e (patch)
treeff647a0e4b772d848d71124f6bd921c467b8422c
parentapp-emacs/magit: add 2.12.1 (diff)
downloadgentoo-f6f30433.tar.gz
gentoo-f6f30433.tar.bz2
gentoo-f6f30433.zip
fix compilation when functions are not inlined
Closes: https://bugs.gentoo.org/629164 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
index 692e9373f3d6..0370d8002246 100644
--- a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
+++ b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
@@ -30,6 +30,9 @@ all_ruby_prepare() {
each_ruby_configure() {
${RUBY} -Cext/mri extconf.rb || die
+
+ # Some methods may not be inlined on x86 but they are not defined either, bug 629164
+ sed -i -e 's:-Wl,--no-undefined::' ext/mri/Makefile || die
}
each_ruby_compile() {