summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-05-02 23:17:04 -0400
committerSam James <sam@gentoo.org>2022-05-14 02:57:11 +0000
commitf707e48b956f834b3beee2cc82435fdb669336e4 (patch)
tree9a2ab5e168be85b3012d2c52ee82f5858f9bb16f
parentx11-wm/marco: add 1.26.0 (diff)
downloadgentoo-f707e48b.tar.gz
gentoo-f707e48b.tar.bz2
gentoo-f707e48b.zip
dev-libs/dietlibc: fix elftrunc segfault during build
Closes: https://bugs.gentoo.org/676704 Bug: https://bugs.gentoo.org/807667 Signed-off-by: matoro <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/25293 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/dietlibc/dietlibc-0.34.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-libs/dietlibc/dietlibc-0.34.ebuild b/dev-libs/dietlibc/dietlibc-0.34.ebuild
index 856d3468195f..d431bc265b2c 100644
--- a/dev-libs/dietlibc/dietlibc-0.34.ebuild
+++ b/dev-libs/dietlibc/dietlibc-0.34.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -24,6 +24,9 @@ src_prepare() {
# Replace sparc64 related C[XX]FLAGS (see bug #45716)
use sparc && replace-sparc64-flags
+ # bug 676704
+ use sparc && tc-is-gcc && append-flags -fno-tree-pre
+
# gcc-hppa suffers support for SSP, compilation will fail
use hppa && strip-unsupported-flags