summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-25 18:16:23 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-26 22:02:54 +0200
commitf71051e0685f783eaf6089fe408ef5dbaf233afd (patch)
treef3465538da0a72fad284c9221dc6f6162f47e02a
parentdev-perl/Tree-Simple: Bump to version 1.270.0 (diff)
downloadgentoo-f71051e0.tar.gz
gentoo-f71051e0.tar.bz2
gentoo-f71051e0.zip
dev-perl/Try-Tiny: Bump to version 0.240.0
- EAPI6 - Fix DESCRIPTION interpolating "$@" - Add optional deps with USE="!minimal" Upstream: - Allow using Sub::Util instead of Sub::Name where its available. Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
-rw-r--r--dev-perl/Try-Tiny/Manifest1
-rw-r--r--dev-perl/Try-Tiny/Try-Tiny-0.240.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Try-Tiny/Manifest b/dev-perl/Try-Tiny/Manifest
index 5919f4af8560..f249e5cd3565 100644
--- a/dev-perl/Try-Tiny/Manifest
+++ b/dev-perl/Try-Tiny/Manifest
@@ -1 +1,2 @@
DIST Try-Tiny-0.22.tar.gz 18311 SHA256 60fba46f4693d33d54539104f9001df008dabb400b6837e9605c39a6ee6a1b19 SHA512 4e39b4da16480bb2b93c05e8e016e9d1b5a68f29c527b19bbf9333442ca708e88dd2720a5812d141a152ae088ed1fcb1ce179018c2d0fe105545256396b2ccc4 WHIRLPOOL 1d260b96ef061e7a8ae605e5168bbac807a93387bcb3e085e2b305b8196fedebbebdaa3ac190edbd4c3772b8fd1e46219e6718ee849b8ae0b1d6e0360a88c82d
+DIST Try-Tiny-0.24.tar.gz 30666 SHA256 9b7a1af24c0256973d175369ebbdc25ec01e2452a97f2d3ab61481c826f38d81 SHA512 403ce12b7cda7356b1a86d7661ed406ce4e526f416033fa5eb04b83bbeb7f198b4660342383232affe2ef9a8e0dbd237a6e6c0f290c277c8abc319c949d3c959 WHIRLPOOL 2aece95a840369d710a1e7249bdf76a1850d7974ccf811f01e399bd68e4927be9343baa38b4c81367c895baaf618c43c30e1e4662412ac27e71bd4b5199eb625
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.240.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.240.0.ebuild
new file mode 100644
index 000000000000..eb0a015213b6
--- /dev/null
+++ b/dev-perl/Try-Tiny/Try-Tiny-0.240.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of \$@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ || ( >=virtual/perl-Scalar-List-Utils-1.400.0 dev-perl/Sub-Name )
+ )
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/Capture-Tiny-0.120.0
+ )
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ virtual/perl-if
+ )
+"