summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-02 10:30:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-02 10:36:45 +0200
commitf71135b1727fec1263a8c8f1f258f2559ebbd859 (patch)
tree447eb5a4b27100c3bee9f06976ed5db8d2f6ced0
parentdev-python/paver: Remove py2.7 (diff)
downloadgentoo-f71135b1.tar.gz
gentoo-f71135b1.tar.bz2
gentoo-f71135b1.zip
dev-python/peewee: Remove old (py2.7)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.1.0.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index f0be807095a6..770386da5c0c 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1 @@
-DIST peewee-3.1.0.tar.gz 705099 BLAKE2B 1dc528082337ae509fc9f91c521d7bf036179ad6b1a5a93e113d594ce819d3a9cdbb7e687b51acacdaf242d542dad138ce2a21f9dcc19483c7361788329a53ed SHA512 628eea27d51017a6ab87aae9ae851d749b0f437fe1806957b23408ad3c97bbb93e5b84c66c5e70bfb7b55c9f29a0c517b84e65adc0f979da450987d670661e84
DIST peewee-3.13.2.tar.gz 871323 BLAKE2B 18fd9729ddd6ce3fe4a6963b697815d44e91b5078ba0b868e6b4f24f4cec9c5b01239d7f414f4f8c0871d3dc6bd5e0e37e218c9438cf1f7461bf729cb74049e4 SHA512 7304473f8e64df7cb2205900cfbdd52346d89e9639dc79ed6e13d5c4c11cc856e39e366772039097dc5ca86b4768fa4670dccd96a85cabfb522c463b31c40a8b
diff --git a/dev-python/peewee/peewee-3.1.0.ebuild b/dev-python/peewee/peewee-3.1.0.ebuild
deleted file mode 100644
index 78dda8ee3b05..000000000000
--- a/dev-python/peewee/peewee-3.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-DEPEND="dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- sed -i -e "s#test_suite='tests',##g;" ./setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Testsuite run using runtests.py does not require deps listed in previous ebuild
- "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && DOCS=( examples/ )
- distutils-r1_python_install_all
-}