summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-17 15:46:29 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-17 16:11:35 +0200
commitf714c19448624808fdb8c3f81b598be86d980479 (patch)
tree441ceb515aec9f7fd513bfe982e196cc781fab70
parentnet-libs/libmbim: Version bump to 1.14.0, remove faulty 9999 ebuild. (diff)
downloadgentoo-f714c194.tar.gz
gentoo-f714c194.tar.bz2
gentoo-f714c194.zip
sci-libs/geos: Allow for compiling with GCC 6
Gentoo-bug: 593934 * Patches taken from Upstream trunk Package-Manager: portage-2.3.0
-rw-r--r--sci-libs/geos/files/geos-3.5.0-autoconf-detect-isnan.patch25
-rw-r--r--sci-libs/geos/files/geos-3.5.0-std-isnan.patch26
-rw-r--r--sci-libs/geos/geos-3.5.0-r2.ebuild2
3 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/geos/files/geos-3.5.0-autoconf-detect-isnan.patch b/sci-libs/geos/files/geos-3.5.0-autoconf-detect-isnan.patch
new file mode 100644
index 000000000000..79e319da493e
--- /dev/null
+++ b/sci-libs/geos/files/geos-3.5.0-autoconf-detect-isnan.patch
@@ -0,0 +1,25 @@
+From edbeee650287a4a36837e090eafed90a760bad83 Mon Sep 17 00:00:00 2001
+From: Sandro Santilli <strk@keybit.net>
+Date: Mon, 7 Mar 2016 10:21:33 +0000
+Subject: [PATCH] Look for isnan in std:: namespace
+
+Tested with gcc 4.8.4
+
+git-svn-id: http://svn.osgeo.org/geos/trunk@4169 5242fede-7e19-0410-aef8-94bd7d2200fb
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7fdc579..8976a6a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -197,7 +197,7 @@ dnl of isnan().
+ AC_LANG_PUSH([C++])
+ AC_CACHE_CHECK([for isnan], ac_cv_isnan,
+ [AC_TRY_LINK([#include <cmath>],
+- [double x; int y; y = isnan(x);],
++ [double x; int y; y = std::isnan(x);],
+ ac_cv_isnan=yes,
+ ac_cv_isnan=no
+ )])
diff --git a/sci-libs/geos/files/geos-3.5.0-std-isnan.patch b/sci-libs/geos/files/geos-3.5.0-std-isnan.patch
new file mode 100644
index 000000000000..c2b6a996afcd
--- /dev/null
+++ b/sci-libs/geos/files/geos-3.5.0-std-isnan.patch
@@ -0,0 +1,26 @@
+From a9bb3ed34e71f5f9d1d1b0bc3044555a0b3b932c Mon Sep 17 00:00:00 2001
+From: Sandro Santilli <strk@keybit.net>
+Date: Thu, 14 Jul 2016 10:38:35 +0000
+Subject: [PATCH] Fully qualify isnan call when HAVE_ISNAN is defined
+
+Fixes build with GCC-5.3.0 and higher.
+Closes #784
+
+git-svn-id: http://svn.osgeo.org/geos/trunk@4224 5242fede-7e19-0410-aef8-94bd7d2200fb
+---
+ include/geos/platform.h.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/geos/platform.h.in b/include/geos/platform.h.in
+index d8d4558..c3bc9c8 100644
+--- a/include/geos/platform.h.in
++++ b/include/geos/platform.h.in
+@@ -86,7 +86,7 @@ extern "C"
+ #endif
+
+ #if defined(HAVE_ISNAN)
+-# define ISNAN(x) (isnan(x))
++# define ISNAN(x) (std::isnan(x))
+ #else
+ # if defined(_MSC_VER)
+ # define ISNAN(x) _isnan(x)
diff --git a/sci-libs/geos/geos-3.5.0-r2.ebuild b/sci-libs/geos/geos-3.5.0-r2.ebuild
index e7d6e01600f1..79b1c943da17 100644
--- a/sci-libs/geos/geos-3.5.0-r2.ebuild
+++ b/sci-libs/geos/geos-3.5.0-r2.ebuild
@@ -37,6 +37,8 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/3.4.2-solaris-isnan.patch
+ "${FILESDIR}"/${PN}-3.5.0-std-isnan.patch
+ "${FILESDIR}"/${PN}-3.5.0-autoconf-detect-isnan.patch
"${FILESDIR}"/${P}-phpconfig-path.patch
)