summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 08:45:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 09:35:15 +0100
commitf717481c5275876d6a549b31368a42d6a4f439bc (patch)
treed6612c9c0ceb7e740c6526a04253ed5f02f6f4a4
parentdev-python/construct: Bump to 2.10.58 (diff)
downloadgentoo-f717481c.tar.gz
gentoo-f717481c.tar.bz2
gentoo-f717481c.zip
dev-python/hypothesis: Bump to 6.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.0.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e773b458ba8e..7e5697ccde94 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-5.49.0.tar.gz 9103591 BLAKE2B 158cbc38f6f2407d437656a7b94
DIST hypothesis-python-6.0.1.tar.gz 9104122 BLAKE2B c4702a2c94fb5ecfc44543b70995150090949067ca986f5671a936d5da651e2e1ed072457ed1238ae04549709019722f7501ff7c2a37c46da3d25b43fa416b08 SHA512 3981a40ba61ca38140582f46b1ebb1ac2fc0816e8210c37ddc91249515d035534208c6ba926f367607bbd79792383eb166c1f4710a8a5ba5e04876383ac44644
DIST hypothesis-python-6.0.2.tar.gz 9104422 BLAKE2B 1f932e2e2c7f3b3f56863fecfeafe3d811fbc19dbb459b3e7497fb14d6b6ef73bf4c7c60957a4170594805e443a4730d5a0561fb2e6cb3ba10da801ef655a8b9 SHA512 7d3689c6964f5158b4ab7b638d43c44b145080e47b832405c50971ea986b2c78c9be648de78c9783c6adc34e117b90b2c2e4b684783a68acc6bdff51ee085248
DIST hypothesis-python-6.0.3.tar.gz 9104754 BLAKE2B 46b713820790daa60b4a7d56bca4ebc72482e9d39b6b37c929b91eebb1f48324e56206f85de78c7744f65d54dd678075aa040f1a745e56a8db217ffc26f3ced2 SHA512 7762c6a1da52cf21f1fb7333cb6f7d302e825a9fe4ad13b85cf94f5f1b450410ed2bdbc40cff54a23629c758e8513d1a39767e0b415db61a07ff74489573a916
+DIST hypothesis-python-6.0.4.tar.gz 9106652 BLAKE2B 4a35185605476d70ef6c768f4fe76c75341cfe18e7c0ba45e8c1c445f4f49d376bd580fd8b0910fc35b123e5f1756df0c4e848d79789b531bf5b35180980b3b9 SHA512 834b5c19760e9639baba0fcb3e5a09fb1d94c4ab763049e5f16df7fd8db357bc300041293b951a9078752fd05dd9cfd5b39fa45d78742e92ff77a17bb49d3f43
diff --git a/dev-python/hypothesis/hypothesis-6.0.4.ebuild b/dev-python/hypothesis/hypothesis-6.0.4.ebuild
new file mode 100644
index 000000000000..973ce1a66b61
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.0.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}