summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-28 14:55:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-28 14:55:40 +0200
commitf71d450d6f6195702367aa5d509e45f0b21c7554 (patch)
treec1b66f45afaf32295853f32810f6dae121378969
parentdev-ml/ocaml-mysql: bump to 1.2.2 (diff)
downloadgentoo-f71d450d.tar.gz
gentoo-f71d450d.tar.bz2
gentoo-f71d450d.zip
dev-python/envoy: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.1
-rw-r--r--dev-python/envoy/envoy-0.0.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/envoy/envoy-0.0.3-r1.ebuild b/dev-python/envoy/envoy-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..5a7c6b0ccf71
--- /dev/null
+++ b/dev-python/envoy/envoy-0.0.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple API for running external processes"
+HOMEPAGE="https://github.com/kennethreitz/envoy https://pypi.python.org/pypi/envoy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RESTRICT="test"
+
+python_test() {
+ # These unit tests fail, see the following issue:
+ # https://github.com/kennethreitz/envoy/issues/58
+ "${PYTHON}" test_envoy.py || die
+}