summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <JoMull01@protonmail.com>2020-07-24 22:23:15 -0400
committerSam James <sam@gentoo.org>2020-09-04 20:53:51 +0000
commitf75bd8c80827864d0b5420b52b740317d7b846a8 (patch)
tree0bf5568b2995c5739e65aa79edd4259bd294ec02
parentnet-libs/tox: set tests to run with only one thread (diff)
downloadgentoo-f75bd8c8.tar.gz
gentoo-f75bd8c8.tar.bz2
gentoo-f75bd8c8.zip
net-libs/tox: update to tox-9999
This commit includes a rewritten dependencies section, updated Cmake flags, updates to the blacklisted tests, restrictions on parallel tests, and updates to the post install messages. Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/16810 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/tox/tox-9999.ebuild56
1 files changed, 26 insertions, 30 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index 206fb9c4e391..23e322bf207c 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -19,23 +19,25 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="^^ ( log-debug log-error log-info log-trace log-warn )
daemon? ( dht-node )"
-COMMON_DEPEND="
- av? ( media-libs/libvpx
- media-libs/opus )
- daemon? ( acct-group/tox
- acct-user/tox
- dev-libs/libconfig )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom,-minimal]"
BDEPEND="virtual/pkgconfig"
-
-DEPEND="${COMMON_DEPEND}"
-
-RDEPEND="${COMMON_DEPEND}"
+DEPEND=">dev-libs/libsodium-0.6.1:=[asm,urandom,-minimal]
+ av? (
+ media-libs/libvpx:=
+ media-libs/opus
+ )
+ daemon? ( dev-libs/libconfig )"
+RDEPEND="
+ ${DEPEND}
+ daemon? (
+ acct-group/tox
+ acct-user/tox
+ )"
src_prepare() {
cmake_src_prepare
#remove faulty tests
- for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
+ local faultytest=(lan_discovery save_compatibility)
+ for testname in "${faultytest[@]}"; do
sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
done
}
@@ -44,6 +46,7 @@ src_configure() {
local mycmakeargs=(
-DAUTOTEST=$(usex test)
-DBOOTSTRAP_DAEMON=$(usex daemon)
+ -DBUILD_MISC_TESTS=$(usex test)
-DBUILD_TOXAV=$(usex av)
-DDHT_BOOTSTRAP=$(usex dht-node)
-DENABLE_SHARED=ON
@@ -51,12 +54,10 @@ src_configure() {
-DMUST_BUILD_TOXAV=$(usex av))
if use test; then
mycmakeargs+=(
- -DBUILD_AV_TEST=$(usex av)
-DTEST_TIMEOUT_SECONDS=120
-DUSE_IPV6=$(usex ipv6))
else
mycmakeargs+=(
- -DBUILD_AV_TEST=OFF
-DUSE_IPV6=OFF)
fi
@@ -77,6 +78,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ cmake_src_test -j1
+}
+
src_install() {
cmake_src_install
@@ -91,21 +96,12 @@ src_install() {
pkg_postinst() {
if use dht-node; then
- ewarn "There is currently an unresolved issue with tox"
- ewarn "DHT Bootstrap node that causes the program to be"
- ewarn "built with a null library reference. This"
- ewarn "causes an infinite loop for certain rev-dep-rebuild"
- ewarn "commands. If you aren't running a node, please"
- ewarn "consider disabling the dht-node flag"
- fi
- if use daemon; then
- if [[ -f ${EROOT}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
+ ewarn "There is currently an unresolved issuer with tox DHT"
+ ewarn "Bootstrap node that causes the program to be built"
+ ewarn "with a null libray reference. This causes an infinite"
+ ewarn "loop for certain revdep-rebuild commands. If you aren't"
+ ewarn "running a node, please consider disabling the dht node"
+ ewarn "use flag. For more information please refer to"
+ ewarn "https://github.com/toktok/c-toxcore/issues/1144"
fi
}