summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-06-02 14:36:56 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-06-02 14:37:20 +0200
commitf76b4784da63d97557f89ff62937833584c7996e (patch)
tree1fa063d34137cfa8f8628d144da5243aa580134f
parentapp-misc/tmux: Bump to version 2.2 (bug #579620). (diff)
downloadgentoo-f76b4784da63d97557f89ff62937833584c7996e.tar.gz
gentoo-f76b4784da63d97557f89ff62937833584c7996e.tar.bz2
gentoo-f76b4784da63d97557f89ff62937833584c7996e.zip
app-misc/tmux: Bumped live ebuild to EAPI-6. Cleanup.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-misc/tmux/tmux-9999.ebuild37
1 files changed, 16 insertions, 21 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 577675cb612a..223d23a4daef 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -2,11 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils git-r3 bash-completion-r1 flag-o-matic versionator
+inherit autotools git-r3 flag-o-matic versionator
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.github.io/"
@@ -17,12 +15,14 @@ EGIT_REPO_URI="https://github.com/tmux/tmux.git"
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="debug selinux vim-syntax kernel_FreeBSD kernel_linux"
+IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
CDEPEND="
>=dev-libs/libevent-2.0.10
- kernel_linux? ( sys-libs/libutempter )
- kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ utempter? (
+ kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ )
sys-libs/ncurses:0="
DEPEND="${CDEPEND}
virtual/pkgconfig"
@@ -48,29 +48,24 @@ src_prepare() {
# 1.7 segfaults when entering copy mode if compiled with -Os
replace-flags -Os -O2
- autotools-utils_src_prepare
+ default
+
+ eautoreconf
}
src_configure() {
- local myeconfargs=(
- --sysconfdir="${EPREFIX}"/etc
- $(use_enable debug)
- )
- autotools-utils_src_configure
+ econf \
+ --sysconfdir="${EPREFIX}"/etc \
+ $(use_enable debug) \
+ $(use_enable utempter)
}
src_install() {
- autotools-utils_src_install
-
- newbashcomp "${DISTDIR}/tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b" ${PN}
+ default
- docinto examples
- dodoc example_tmux.conf
+ einstalldocs
if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- newins "${DISTDIR}/tmux.vim-95f6126c187667cc7f9c573c45c3b356cf69f4ca" tmux.vim
-
insinto /usr/share/vim/vimfiles/ftdetect
doins "${FILESDIR}"/tmux.vim
fi