summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-02-27 20:11:32 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-02-27 20:11:32 -0500
commitf784e0f7d08a03392eb2affca8a32a858e915118 (patch)
tree8f2b7f697c1df7217f5d639feb61ecfd2d549315
parentdev-python/python3-openid: remove last-rited package (diff)
downloadgentoo-f784e0f7d08a03392eb2affca8a32a858e915118.tar.gz
gentoo-f784e0f7d08a03392eb2affca8a32a858e915118.tar.bz2
gentoo-f784e0f7d08a03392eb2affca8a32a858e915118.zip
dev-python/python-social-auth: remove last-rited package
Closes: https://bugs.gentoo.org/610466 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--dev-python/python-social-auth/Manifest2
-rw-r--r--dev-python/python-social-auth/metadata.xml11
-rw-r--r--dev-python/python-social-auth/python-social-auth-0.1.26.ebuild56
-rw-r--r--dev-python/python-social-auth/python-social-auth-0.2.10.ebuild57
4 files changed, 0 insertions, 126 deletions
diff --git a/dev-python/python-social-auth/Manifest b/dev-python/python-social-auth/Manifest
deleted file mode 100644
index a1f8fffbe259..000000000000
--- a/dev-python/python-social-auth/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST python-social-auth-0.1.26.tar.gz 247579 BLAKE2B 647299350462d707d054df6b64438fd71f2ec28c047a0dda21432a3488d26e1adec86ffe7a1cd09d2a7bc658e661e065df9a06e3058da3c16dfe22b5b85402bb SHA512 c3637f9a269f2c8465b1896840a5ca0f70bb6c45c93f7d9c08c54434037984538ba95442a164841c069cb5b1fd251d0f3f62baa1dc2754a542baceb2f325bd8b
-DIST python-social-auth-0.2.10.tar.gz 297210 BLAKE2B b312211ad11d4d1d1d12dcb607e87064b4bd2cf929c71b513a665839365510e0768151de4b3e56dd9a05fe9d8e4fe7368bc7f234c01f20e3d2898c709102ae29 SHA512 af5247cee0b77f36d1bfdd7457708c2f2053bc779bae8eae0cfe79f0f9236c37882afcbd325863255282eb7559d8f84715b3e983f94d55bd3e7815c5469f150d
diff --git a/dev-python/python-social-auth/metadata.xml b/dev-python/python-social-auth/metadata.xml
deleted file mode 100644
index 2f61c1adb476..000000000000
--- a/dev-python/python-social-auth/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="github">omab/python-social-auth</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild b/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild
deleted file mode 100644
index 7c1e44660d9d..000000000000
--- a/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy to setup social auth mechanism with support for several frameworks and auth providers"
-HOMEPAGE="http://psa.matiasaguirre.net/"
-SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples test"
-
-RDEPEND="
- $(python_gen_cond_dep \
- 'dev-python/python-openid[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep \
- 'dev-python/python3-openid[${PYTHON_USEDEP}]' 'python3*')
- >=dev-python/oauthlib-0.3.8[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
- >=dev-python/six-1.2.0[${PYTHON_USEDEP}]
-"
-DEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-# tests require internet
-#"
-# test? (
-# dev-python/coverage[${PYTHON_USEDEP}]
-# dev-python/httpretty[${PYTHON_USEDEP}]
-# dev-python/mock[${PYTHON_USEDEP}]
-# dev-python/nose[${PYTHON_USEDEP}]
-# dev-python/sure[${PYTHON_USEDEP}]
-# )
-#"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
-
-#python_test() {
-# "${S}"/social/tests/run_tests.sh || die "Tests failed on ${EPYTHON}"
-#}
diff --git a/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild b/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild
deleted file mode 100644
index 8c8f3c7a876e..000000000000
--- a/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy to setup social auth mechanism with support for several frameworks and auth providers"
-HOMEPAGE="http://psa.matiasaguirre.net/"
-SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples test"
-
-RDEPEND="
- $(python_gen_cond_dep \
- 'dev-python/python-openid[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep \
- 'dev-python/python3-openid[${PYTHON_USEDEP}]' 'python3*')
- >=dev-python/oauthlib-0.3.8[${PYTHON_USEDEP}]
- >=dev-python/pyjwt-1.2.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
- >=dev-python/six-1.2.0[${PYTHON_USEDEP}]
-"
-DEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-# tests require internet
-#"
-# test? (
-# dev-python/coverage[${PYTHON_USEDEP}]
-# dev-python/httpretty[${PYTHON_USEDEP}]
-# dev-python/mock[${PYTHON_USEDEP}]
-# dev-python/nose[${PYTHON_USEDEP}]
-# dev-python/sure[${PYTHON_USEDEP}]
-# )
-#"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
-
-#python_test() {
-# "${S}"/social/tests/run_tests.sh || die "Tests failed on ${EPYTHON}"
-#}