summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-23 04:48:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-23 05:03:36 +0100
commitf7912ef79b1dfe22a88bd8a263655273e4f53f01 (patch)
treeac767fafbd90481e23ff054a93e7b73a5d7b444f
parentapp-admin/awscli: Bump to 1.30.6 (diff)
downloadgentoo-f7912ef79b1dfe22a88bd8a263655273e4f53f01.tar.gz
gentoo-f7912ef79b1dfe22a88bd8a263655273e4f53f01.tar.bz2
gentoo-f7912ef79b1dfe22a88bd8a263655273e4f53f01.zip
dev-python/trimesh: Bump to 4.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.0.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index f41f017ac49f..863e6e837816 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-4.0.2.gh.tar.gz 13433444 BLAKE2B a466adc4708e7f59cb7a64f3872df89888ad21a4f78520c5f109c101ea5d42973705e59807dd800058f3925744a30cc6ddd88fa498533f7e69255ba0c5d652e2 SHA512 7c0c8cbf40f03f4fd92156306f0a0d4d0a1dbf774c9a1743d63d82be2264b50915f2f6ea2cdebd0e81390e7f96acb47eca9980f3829311ec027706ef1cc143c0
DIST trimesh-4.0.4.gh.tar.gz 13434249 BLAKE2B 209ebbd8840e264bdde1aa6bf71b07910032ea3b577c4253cc66128761a2b1e1c9447c923d08108e36ddf5bf76ba67c90b728af4e18cea25882f78e4f252c18b SHA512 1135b626efc7559c2c127852f2947bf1d659b67a3bb16baf6d3fc795ab81baca1a57f035ce2ff0bdaa61709d0a21a160bbf425717037dd9662295e83894786bc
+DIST trimesh-4.0.5.gh.tar.gz 13433920 BLAKE2B d7979727f4595dedd4d58bd7373bff457e008ea9512fb5aaa3c0e297fb0e9e538ab3b62e6d231bb6d0d7c8499e346c88b89878489187248bfd77116b4ab733dd SHA512 5167f93aece58d0fd2766a41afb5651df2ffac6486e3aebae33d97ed1ae2e4093290450b1e8d7827c300c679cf4c93baf7ce44ec603103a70c510259f514d321
diff --git a/dev-python/trimesh/trimesh-4.0.5.ebuild b/dev-python/trimesh/trimesh-4.0.5.ebuild
new file mode 100644
index 000000000000..efd16dd10381
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}