summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-15 08:18:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-15 08:32:06 +0200
commitf791e9b28a5d721a4febe443b83d59e3be349f54 (patch)
tree56e270e73414c3dbfce01a74823e88140de3a4e6
parentdev-python/xxhash: Bump to 2.0.2 (diff)
downloadgentoo-f791e9b2.tar.gz
gentoo-f791e9b2.tar.bz2
gentoo-f791e9b2.zip
dev-python/py-cpuinfo: Bump to 8.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/py-cpuinfo/Manifest1
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/Manifest b/dev-python/py-cpuinfo/Manifest
index 408f4b9ca039..c4f14401421b 100644
--- a/dev-python/py-cpuinfo/Manifest
+++ b/dev-python/py-cpuinfo/Manifest
@@ -1,2 +1,3 @@
DIST py-cpuinfo-6.0.0.tar.gz 145260 BLAKE2B 58cfeb698619f2f51dada63b236969393e387f6e66fffe853ab633e438b4b893489c097211a20ece597a06d3c0cf89d285b5ab34e80029510e86b1a322ff1f06 SHA512 4941a5193cc376a44e99bc82644ec9d7e8f9f11b4e5fb1ad22a71c959959dde7f67290b436dfad2f26c68ef17d08e33538cf80443f763268c503af17b8479438
DIST py-cpuinfo-7.0.0.tar.gz 95887 BLAKE2B 8f5764db94faf41dc554353ac2a21416998efd602b6228f21db6e5b3257563b4f7352221eb7f354ebe431910b0b8dadd52558233261df557c6a7943b7ec138c4 SHA512 fd291533dc5e78d75851e61ef2a754d9bdb62cbb5e04c86db0d6ea2d074a1e920b1ff50c136df3dd640cb64deaccd4f187c5af02c586a3d28b8c74dfe4143893
+DIST py-cpuinfo-8.0.0.tar.gz 99791 BLAKE2B 95024b488142e3bbb2eaa69ffef229ac27f1cb55e297fb8de050ec4c410c1b13dbf674936365d84c5c473158338dd047f6dfba58c2a7dde4e21232af356ab20c SHA512 77351f9f2fd33b09d0ee998dd2b3eb971bbe9094bee5636356d5a5a2747ebba3c112cccfdf929f77e3b7de3c745f98ecfac8edeb0d84fede100b637b554d4fd9
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild
new file mode 100644
index 000000000000..944389530103
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="
+ https://github.com/workhorsy/py-cpuinfo/
+ https://pypi.org/project/py-cpuinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests setup.py