summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-26 18:49:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-27 13:40:38 +0100
commitf794393c387771b153227d45201f841e71202af6 (patch)
tree27628add9f46643f10776707ab82f80c0939fe36
parentdev-ml/ocamlbuild: bump to 0.10.1 (diff)
downloadgentoo-f794393c.tar.gz
gentoo-f794393c.tar.bz2
gentoo-f794393c.zip
dev-ml/opam: bump to 1.3.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/opam-1.3.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 144449c711f5..e8ec3ff4c5b4 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -1 +1,2 @@
DIST opam-1.2.2.tar.gz 648951 SHA256 3e4a05df6ff8deecba019d885ebe902eb933acb6e2fc7784ffee1ee14871e36a SHA512 12105b5219a14d4c4cb29c387dd5af858d2b4a2a1bad7dcd70e4c284fc52848df82933396571b85251d904b3c14cdf02db55060c1ba29dc34b8bab3721d05f54 WHIRLPOOL 97d6ab75620a4ed18b45d80e88e77564af457606cbb8dd4591030574bfdbff5c16d508e81438b78198b87511151b1b030e6a51c2370e3110ae21216846f37836
+DIST opam-1.3.0.tar.gz 669389 SHA256 9d50122940f44401c2dcee39b12a4e4afea851b2f2ab47d90b522f7395f10f7a SHA512 290535a1bb2e7eff6ab44126c5070d2bed94e68cee3bd5e47054f91ad81ed92e9a21f7888bd1dafcb397e3ac61589d4eaf7267305ac63d1aee08761701bdf647 WHIRLPOOL 64b8fc334b8dd193af1d4ae0d0bb445554f6afeb3007fefd4048816d1bd90363c7b18c4d44521da8162bc3ae49668d26b75ef811a4de4d5287597024d0b74ddd
diff --git a/dev-ml/opam/opam-1.3.0.ebuild b/dev-ml/opam/opam-1.3.0.ebuild
new file mode 100644
index 000000000000..6d7f7d32857e
--- /dev/null
+++ b/dev-ml/opam/opam-1.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+DEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-5:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+RDEPEND="${DEPEND}
+ dev-ml/findlib
+"
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}