summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-07-30 10:53:55 -0400
committerMike Gilbert <floppym@gentoo.org>2016-07-30 11:46:34 -0400
commitf7b360c6da771f540d58fa6d83fb718c47be9e6d (patch)
tree4e7296875f2c79bb60d62cd4a1f78e687d45cdc0
parentsys-apps/systemd: update resolv.conf warning (diff)
downloadgentoo-f7b360c6da771f540d58fa6d83fb718c47be9e6d.tar.gz
gentoo-f7b360c6da771f540d58fa6d83fb718c47be9e6d.tar.bz2
gentoo-f7b360c6da771f540d58fa6d83fb718c47be9e6d.zip
sys-apps/systemd: drop migrate_net_name_slot
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index b0e8183ab0a4..a6151d15f732 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -400,34 +400,6 @@ migrate_locale() {
fi
}
-migrate_net_name_slot() {
- # If user has disabled 80-net-name-slot.rules using a empty file or a symlink to /dev/null,
- # do the same for 80-net-setup-link.rules to keep the old behavior
- local net_move=no
- local net_name_slot_sym=no
- local net_rules_path="${EROOT%/}"/etc/udev/rules.d
- local net_name_slot="${net_rules_path}"/80-net-name-slot.rules
- local net_setup_link="${net_rules_path}"/80-net-setup-link.rules
- if [[ -e ${net_setup_link} ]]; then
- net_move=no
- elif [[ -f ${net_name_slot} && $(sed -e "/^#/d" -e "/^\W*$/d" ${net_name_slot} | wc -l) == 0 ]]; then
- net_move=yes
- elif [[ -L ${net_name_slot} && $(readlink ${net_name_slot}) == /dev/null ]]; then
- net_move=yes
- net_name_slot_sym=yes
- fi
- if [[ ${net_move} == yes ]]; then
- ebegin "Copying ${net_name_slot} to ${net_setup_link}"
-
- if [[ ${net_name_slot_sym} == yes ]]; then
- ln -nfs /dev/null "${net_setup_link}"
- else
- cp "${net_name_slot}" "${net_setup_link}"
- fi
- eend $? || FAIL=1
- fi
-}
-
reenable_unit() {
if systemctl is-enabled --root="${ROOT}" "$1" &> /dev/null; then
ebegin "Re-enabling $1"
@@ -467,9 +439,6 @@ pkg_postinst() {
# between OpenRC & systemd
migrate_locale
- # Migrate 80-net-name-slot.rules -> 80-net-setup-link.rules
- migrate_net_name_slot
-
# Re-enable systemd-networkd for socket activation
reenable_unit systemd-networkd.service