summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-06-15 07:53:32 -0300
committerMatt Turner <mattst88@gentoo.org>2023-06-15 09:49:32 -0400
commitf7befe1f4a35050cb0bf37701b3bd1c17e11bb9c (patch)
tree3e8e858437c992f8870a9a91c489bf130ffefe35
parentapp-admin/exo: remove old (diff)
downloadgentoo-f7befe1f4a35050cb0bf37701b3bd1c17e11bb9c.tar.gz
gentoo-f7befe1f4a35050cb0bf37701b3bd1c17e11bb9c.tar.bz2
gentoo-f7befe1f4a35050cb0bf37701b3bd1c17e11bb9c.zip
dev-libs/gjs: Version bump to 1.76.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31451 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.76.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 42cbc07a036e..833b0bcc0a94 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,2 +1,3 @@
DIST gjs-1.76.0.tar.xz 645364 BLAKE2B 9987033883e466c983af007c870cba4f2ef70ee08e276777e1b52103ddcebd1285ca9f3ce64c8ef52437a829157f58902cfb921eed06442e53fd9778d9cd9f2b SHA512 fa44431f431f14b82c648c388046b83722808db52d2bbe2deeb8d270d6fbeee9c4ee27feaa4fef425e1ab5ac65a1e68d7aa9457d543044362752810128064ea6
DIST gjs-1.76.1.tar.xz 645888 BLAKE2B 8d37a23080cbacec616af66b482685a05d0dbbf481b6b8f16ac319da0630597aaee223098aea3866644a99bfc28f55933c8f1a6458d82e902c53d0f6dc957fa6 SHA512 30d1da0296a3ae4ec7e7a67a850d10dbc1bf6ac699d2a9d58280b98ee5506bc76b801d62a3c5f964b38995ceda669946df26af51c96417374ff283def7bc7bc1
+DIST gjs-1.76.2.tar.xz 646232 BLAKE2B 66466eeb5f956d5041f4e63ba977dc9a688455770c39bcedd63576f56fde9821ed3c827c470f7e3befbbf7828fbd197706637da458876ec129d6c16323e414e8 SHA512 26b024874ce69a6f58b5fabe006b8d5417971db9de00e21ecd352715b4535f405d162bb81c0cf6b20313f0f78833962080ac1cb9bd42cfff9cf6a74340458540
diff --git a/dev-libs/gjs/gjs-1.76.2.ebuild b/dev-libs/gjs/gjs-1.76.2.ebuild
new file mode 100644
index 000000000000..1806edd6bfdd
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.76.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.71.1:=
+ >=dev-lang/spidermonkey-102.2.0:102
+ cairo? ( x11-libs/cairo[X,glib] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.76.0-move_have_gtk4_to_the_appropriate_place.patch"
+)
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}