summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-15 00:29:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-15 00:29:45 +0200
commitf7c47b8732a8e9f48d7775fc8de94ea743196dd9 (patch)
treec2668c8050fcfc8dd0f2bc65779a6d7d0dc7f145
parentdev-python/pallets-sphinx-themes: Remove old (diff)
downloadgentoo-f7c47b87.tar.gz
gentoo-f7c47b87.tar.bz2
gentoo-f7c47b87.zip
dev-python/flask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask/Manifest2
-rw-r--r--dev-python/flask/flask-1.1.2-r1.ebuild51
-rw-r--r--dev-python/flask/flask-2.0.0-r1.ebuild47
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 8523b8e5ed98..b4b785b2121e 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,4 +1,2 @@
-DIST Flask-1.1.2.tar.gz 637516 BLAKE2B 90dffbb8faa48489d1c71ff2a064d41e97d2103c07532fd5b252dbe0b32e4babb815e31f0ceae201a66cead645b68149d13d4bb39a0df1b27b4002e613920493 SHA512 9feb6a9a8f34fadbea508d465f73c24b1d81b3f66243804dc3904d198c2fd78e2e1bef94df6a4940a7eec6b9b54abea06557a87de8b27b0a9497d18b3e071384
DIST Flask-1.1.4.tar.gz 635920 BLAKE2B c1f19e7449177ecf6e901d5932ad25cbe866ff53b9323f717541922b1ea5b10203ff07630fcf3eabaedd9b6a24ef031ad2aaa2e2f759925363bebfa7e5d967da SHA512 6f427a1264921b8560446afacee2757d16de0dc22d6ed249b7bc5d6f50f3af50c89b79ce900d75b41af4befc53910f2b532c2e280de42837e2133acb6b1bd80d
-DIST Flask-2.0.0.tar.gz 624458 BLAKE2B 82f552cbe714ea4fd64b56f88ee747c292659181139eae5fe0e496457d1f33cb5d7b464ed5250b6087c859691d89cb72a885d8640855dd9dfe7ecc6083bb0c36 SHA512 3fc66aa1568f7dce67bb70b0113401b7535dda32e33ac784a42f08fa21e08b055214218fac06dc6fb4b8f975b2a91321a6c97203f6568efc6bfbbb8d4ef9ddc3
DIST Flask-2.0.1.tar.gz 626851 BLAKE2B 05273edacd6d66237a552410df7ef7ff367e28c273cc89f654eac5ed2eb3d26f71437169905372b398cc6c5c5067dcbea54aa1cab782e03c6186ac9ae3949f4c SHA512 fefed4971f0542b25ba2867919aa54a83b6e3f47e7cee94586543843e7e00ba209ac15d8fe28a3c53981f587aebcf2f3915a49e1a9cd1b729099dccbed3783c2
diff --git a/dev-python/flask/flask-1.1.2-r1.ebuild b/dev-python/flask/flask-1.1.2-r1.ebuild
deleted file mode 100644
index 540b1b3b26b6..000000000000
--- a/dev-python/flask/flask-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/click[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.15[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs
-
-python_test() {
- PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- pytest -vv -p no:httpbin || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-2.0.0-r1.ebuild b/dev-python/flask/flask-2.0.0-r1.ebuild
deleted file mode 100644
index aa5080465c2d..000000000000
--- a/dev-python/flask/flask-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}