summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-29 21:34:50 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-29 21:35:06 -0400
commitf7e7342f84fbaca8640ca8941e6d07202955848f (patch)
tree8e983a5a67aea75c066f6261419ba5fd9c2db960
parentapp-text/convertlit: new revision supporting $(AR). (diff)
downloadgentoo-f7e7342f.tar.gz
gentoo-f7e7342f.tar.bz2
gentoo-f7e7342f.zip
dev-python/pyyaml: version bump to 3.12
-rw-r--r--dev-python/pyyaml/Manifest1
-rw-r--r--dev-python/pyyaml/pyyaml-3.12.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyyaml/Manifest b/dev-python/pyyaml/Manifest
index 9d5479133ce8..07652ecb2f11 100644
--- a/dev-python/pyyaml/Manifest
+++ b/dev-python/pyyaml/Manifest
@@ -1 +1,2 @@
DIST PyYAML-3.11.tar.gz 248685 SHA256 c36c938a872e5ff494938b33b14aaa156cb439ec67548fcab3535bb78b0846e8 SHA512 76de005f59e1842108399af53178cfac2c08ee5cc996cc38ab6ec8b046c6b894422c461a1f1ed1df91abf96f154d41170227912cae7336cff88adfd3c0e8d783 WHIRLPOOL 9b457a026a57d4b90e52629dafbd48a33ff3bf3a71c531857d33acfb7e7033b963c566d82d4fabaa0ae17f534b9d5a697a2407bdb24ab3ca9fd375b49e7932c2
+DIST PyYAML-3.12.tar.gz 253011 SHA256 592766c6303207a20efc445587778322d7f73b161bd994f227adaa341ba212ab SHA512 e16d8b7f4f026b6a95b11fb59c54ec5f114f6f516294eaa95e718abdf5d37c17a9c4b5e0a0a61fca04e801792d9b7fb801087cf849ff22b9581f6af204b1883a WHIRLPOOL ccea5e8931b8c57958f0cca0c58dfe71c42e878b233ba4d9a08aa361b874c06967998bb460772e311b42ecf4cb012a35c3aa9dbff620c6f413bbad8e3fffbaaf
diff --git a/dev-python/pyyaml/pyyaml-3.12.ebuild b/dev-python/pyyaml/pyyaml-3.12.ebuild
new file mode 100644
index 000000000000..b6965b856206
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="http://pyyaml.org/wiki/PyYAML https://pypi.python.org/pypi/PyYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="examples libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}
+ libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}