summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 08:13:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 08:47:12 +0200
commitf7ee93645d39443a1e692c967200117b873794c9 (patch)
tree142d20c30267d46391a4761aa856d1a19f8eba20
parentdev-python/wstools: Enable py3.11 (diff)
downloadgentoo-f7ee93645d39443a1e692c967200117b873794c9.tar.gz
gentoo-f7ee93645d39443a1e692c967200117b873794c9.tar.bz2
gentoo-f7ee93645d39443a1e692c967200117b873794c9.zip
dev-python/extras: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/extras/extras-1.0.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/extras/extras-1.0.0-r2.ebuild b/dev-python/extras/extras-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..354e4692dc08
--- /dev/null
+++ b/dev-python/extras/extras-1.0.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful extra bits for Python that should be in the standard library"
+HOMEPAGE="
+ https://github.com/testing-cabal/extras/
+ https://pypi.org/project/extras/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest