summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-10-02 02:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-10-02 13:45:11 -0400
commitf7fd9853332d49dfc797b4f0522d714145ff967a (patch)
tree5973084ca92d1103e72a6ee3bab716c200fed902
parentapp-i18n/fcitx-m17n: Use cmake.eclass. (diff)
downloadgentoo-f7fd9853.tar.gz
gentoo-f7fd9853.tar.bz2
gentoo-f7fd9853.zip
app-i18n/fcitx-rime: Use cmake.eclass.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild4
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
index e50bc4d56d1f..18b40399bbf0 100644
--- a/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -39,7 +39,7 @@ src_configure() {
-DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
index 4be868b10750..49fb4753f008 100644
--- a/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
+++ b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -52,7 +52,7 @@ src_configure() {
-DENABLE_QT5GUI=$(usex configuration_tool)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {