summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 12:51:06 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 12:54:53 +0100
commitf80110f12b1a2e1758247dce0ef3567ac9dfd4f3 (patch)
treeacc4e5e6c6ae983c5eb9d68bda7ebb041c25c30a
parentdev-python/pytest: Stabilize 7.2.1 ALLARCHES, #892716 (diff)
downloadgentoo-f80110f1.tar.gz
gentoo-f80110f1.tar.bz2
gentoo-f80110f1.zip
dev-python/pdm-pep517: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pdm-pep517/Manifest1
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-1.1.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pdm-pep517/Manifest b/dev-python/pdm-pep517/Manifest
index 2223c9ca6d29..2cdd1a386949 100644
--- a/dev-python/pdm-pep517/Manifest
+++ b/dev-python/pdm-pep517/Manifest
@@ -1,3 +1,2 @@
DIST pdm-pep517-1.0.6.gh.tar.gz 315755 BLAKE2B 7b221d9ddc9683521e901177cafd2ffd2908af4acbe083b4a7d6525a81ece64d3768331135451d45ffc5c40c67c8c72802d75d52fdf85fa89a13f30110436a13 SHA512 5aeef3179d508d2acaedf4b99df41e64b26537120e586a01870651d2b379e2e5a1bf42934ee28a4b285cb83fe10ead073408b6b7d022ca1f55653533d12a2da1
-DIST pdm-pep517-1.1.0.gh.tar.gz 315971 BLAKE2B 679cdd14633a5d745be4dcb215986386464dbdcc91a69a7aaec4910cca7a6c1f65dab8e1a4710715873fae9b0fd07732e8df8a4859155864df330bfda7bfd120 SHA512 b12eeaf294556cdf79e4dc5bfd1d0dc57df64ed632ae678b00452f62b6d48eaf8b7f9437a8f7eec9ecc779d4da3155f3c4923fcdba814cbd1a4575e8f79cecd4
DIST pdm-pep517-1.1.1.gh.tar.gz 234424 BLAKE2B 7bf64c741c6e0e135d8d2358c7eee0777af792a32a825813e1d8dddbfeeeacfb232861dec063ba18a8f8f3587748bb63706a225114eaa60dcc02b40ce8a9ae5c SHA512 5ea8beb0275a2faae9b13c0f13da0f6d3ed8f3bf8f46572b9805daec6174fbfadc093158608b7b6ede4b682240d39edf904d2ad412c1fbdf4054ecb0b6d01283
diff --git a/dev-python/pdm-pep517/pdm-pep517-1.1.0.ebuild b/dev-python/pdm-pep517/pdm-pep517-1.1.0.ebuild
deleted file mode 100644
index 438b25782acb..000000000000
--- a/dev-python/pdm-pep517/pdm-pep517-1.1.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-# upstream has renamed the repo but the legacy branch is still published
-# as pdm-pep517, sigh
-MY_P=pdm-backend-${PV}
-DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
-HOMEPAGE="
- https://pypi.org/project/pdm-pep517/
- https://github.com/pdm-project/pdm-backend/
-"
-SRC_URI="
- https://github.com/pdm-project/pdm-backend/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
- dev-python/license-expression[${PYTHON_USEDEP}]
- =dev-python/packaging-21*[${PYTHON_USEDEP}]
- >=dev-python/tomli-2[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-# setuptools are used to build C extensions
-RDEPEND+="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- rm -r pdm/pep517/_vendor || die
- find -name '*.py' -exec sed \
- -e 's:from pdm\.pep517\._vendor\.:from :' \
- -e 's:from pdm\.pep517\._vendor ::' \
- -i {} + || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- git config --global user.email "test@example.com" || die
- git config --global user.name "Test User" || die
- distutils-r1_src_test
-}