summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2018-11-17 13:02:45 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-22 21:25:24 +0100
commitf801fe79ed738aeef1282f62370109a943674a40 (patch)
treeb5e87e2c8ac9203bbaa877d3dc94ef73811ec907
parentdev-python/markups: Bump to 3.0.0 and add myself as PM (diff)
downloadgentoo-f801fe79.tar.gz
gentoo-f801fe79.tar.bz2
gentoo-f801fe79.zip
app-editors/retext: Bump to 7.0.4 and add python3_7 support
Closes: https://bugs.gentoo.org/668428 Signed-off-by: Nils Freydank <holgersson@posteo.de> Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-editors/retext/Manifest1
-rw-r--r--app-editors/retext/retext-7.0.4.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index 1b03448f9549..3e3af4c752a1 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1,3 +1,4 @@
DIST ReText-7.0.0.tar.gz 203294 BLAKE2B 613004d9e2aaba52e25dec49270ecaf429f5c9dd27041cf09c8b1eefca59e2116b9904b49f260c6bc2528d65fa846a0cd11930d05297b8567e69086376d411a6 SHA512 0a2e430659e7d87d50780fecbf5f04f852f144d143ec83b90126ab9e7b8006756cbc8710c9cec192ddad2cba9f7236e684fa207e308c565388ede308da3c1a35
DIST ReText-7.0.1.tar.gz 266582 BLAKE2B 9a2bf5ee433550b9df777fc65254bf52097730143e491fa52b2312709473905caf45fc63fe96ac04adb94bdbc9ea8e8840c4e5d65cb0da25727d3cdd198d2f97 SHA512 eb6b1f6df1e490d9058f3431c023119afff05e81917bb5402a35a100538283a157d2853d10c015a415a5d7e78aac4a2489307a0ef60004d48d8b1f9207a07567
DIST ReText-7.0.3.tar.gz 396334 BLAKE2B f40ffb159f94d28f1649561a41f557a5d11c2d00e4a01a99493ecac9795bca41c4675bc364c3c58e557bd78c2803f774793042426921436b4be43129f3c88170 SHA512 67b16dc2d7207cc72a58a5ede7440b191c8afdd08e6d4b21159e781585ca16ddfb4d0d16052fc50d716e2edfd983559e25c22ac80dd408cdb3fdb82a2f6bce57
+DIST ReText-7.0.4.tar.gz 402934 BLAKE2B bae66a5fb8e81192d692d1a239706e2feee6ee940685cffdf3498880b2c9bd67cc85c6150e372a383e4bad13da210426fff95c06b2861b58020c2c6d298cf5d2 SHA512 cb12666b15414f4bf83f3b07c94d3bcba13dd3e6c3832c66520bfe8caafeeb87cc083a1e74530d98d6e00a00363add55fdf873e6de385e637876454130deebb3
diff --git a/app-editors/retext/retext-7.0.4.ebuild b/app-editors/retext/retext-7.0.4.ebuild
new file mode 100644
index 000000000000..9067cf820ea2
--- /dev/null
+++ b/app-editors/retext/retext-7.0.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# no pypy{,3} support as PyQt5 does not support it at 2018-11-18
+# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1 gnome2-utils virtualx xdg-utils
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+spell"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/markups[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,network,printsupport,webengine,widgets,${PYTHON_USEDEP}]
+ spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( x11-base/xorg-server[xvfb] )
+"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}