summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 09:29:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 10:51:26 +0200
commitf807f6c4534478a579c5cca5a1494339b7b56df4 (patch)
tree1bc63db81e84b4077cbe534b55a9e8ca0bf2a7d6
parentmedia-video/ccextractor: EAPI-6 bump, HOMEPAGE, cleanup (diff)
downloadgentoo-f807f6c4.tar.gz
gentoo-f807f6c4.tar.bz2
gentoo-f807f6c4.zip
media-video/ccextractor: Install docs
Bug: https://bugs.gentoo.org/651524 Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--media-video/ccextractor/ccextractor-0.85-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-video/ccextractor/ccextractor-0.85-r2.ebuild b/media-video/ccextractor/ccextractor-0.85-r2.ebuild
new file mode 100644
index 000000000000..1ae06ed2d101
--- /dev/null
+++ b/media-video/ccextractor/ccextractor-0.85-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="https://www.ccextractor.org/"
+SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}/src"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ../docs/*.TXT
+}