summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 08:24:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:29 +0100
commitf813fa69cc167dccad6887afd383beea6d636c72 (patch)
tree90e3e84af10076071fdf36deba0c01025e82bf5a
parentdev-python/python-cstruct: Bump to 4.0 (diff)
downloadgentoo-f813fa69.tar.gz
gentoo-f813fa69.tar.bz2
gentoo-f813fa69.zip
dev-python/Babel: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Babel/Babel-2.11.0.ebuild62
-rw-r--r--dev-python/Babel/Manifest1
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.11.0.ebuild b/dev-python/Babel/Babel-2.11.0.ebuild
new file mode 100644
index 000000000000..02e77dc3bc66
--- /dev/null
+++ b/dev-python/Babel/Babel-2.11.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+# see scripts/download_import_cldr.py
+CLDR_PV=41.0
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="
+ https://babel.pocoo.org/
+ https://pypi.org/project/Babel/
+ https://github.com/python-babel/babel/
+"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://unicode.org/Public/cldr/${CLDR_PV%.*}/cldr-common-${CLDR_PV}.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+# RDEPEND in BDEPEND for import_cldr.py usage, bug #852158
+BDEPEND="
+ app-arch/unzip
+ ${RDEPEND}
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm babel/locale-data/*.dat || die
+ rm babel/global.dat || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ if [[ ! -f babel/global.dat ]]; then
+ "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
+ fi
+}
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index ca0439ebbaa5..80aea76c8015 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,2 +1,3 @@
DIST Babel-2.10.3.tar.gz 9344140 BLAKE2B c21d1e33160de2c98ac26b6ac83102a6249cbaf4b4860cd86e19b461ee66fd815a2972fc3652b411e2030b201bf32db77144fde91efc4e9e6ba51a580cad93b7 SHA512 72a5759d2cfa239df56f3d2809b23367b9691e21de92535b30f9b3455d253682f6c18ca919f3fb039deed2663db9276307f6343cbbab56fca96ff1ac9c214fa7
+DIST Babel-2.11.0.tar.gz 9346097 BLAKE2B 99ae97e4dc16e1757ae6f054f9f346c6728d087bbfba33786d59211ac4b6c12bf861c79ac7c12a3efd89539220126ea1ea9a3578a9008daaa464aed315102b60 SHA512 526368dc5e44f2d93c52f2fcb544130eea6c6b7c78325bd56c6d9a6706890a4cd9daa1498d639aab65059801d87977da626e64585083c58c4b328001991eea0b
DIST cldr-common-41.0.zip 29364494 BLAKE2B 1960e860017c3e5f31d935d66a1ff551720975dca0af459adc72b8dc54100938fbd2d2ef00eb457f3fd04d4f1e90a4783229c350b125029dcda5c1e6903f9a54 SHA512 c64f3338e292962817b043dd11e9c47f533c9b70d432f83e80654e20f4937c72b37e66a60485df43f734b1ff94ebf0452547a063076917889303c9653b4d6ce5