summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 06:14:30 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:22 +0000
commitf820b218e398948a1c51a969b1822f0ab91508d8 (patch)
tree97838272dff3dda4bf58119c29a95fc23e596b78
parentfindlib.eclass: minor style changes (diff)
downloadgentoo-f820b218e398948a1c51a969b1822f0ab91508d8.tar.gz
gentoo-f820b218e398948a1c51a969b1822f0ab91508d8.tar.bz2
gentoo-f820b218e398948a1c51a969b1822f0ab91508d8.zip
games-arcade/retrobattle: eutils->wrapper
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild
index e283c6299a0f..7bbb9fa2dc2b 100644
--- a/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild
+++ b/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild
@@ -1,29 +1,32 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop eutils
+inherit desktop wrapper
MY_P="${PN}-src-${PV}"
DESCRIPTION="A NES-like platform arcade game"
HOMEPAGE="http://remar.se/andreas/retrobattle/"
SRC_URI="http://remar.se/andreas/retrobattle/files/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
# test is incomplete
RESTRICT="test"
-DEPEND="media-libs/libsdl[X,sound,video]
- media-libs/sdl-mixer[wav]"
+DEPEND="
+ media-libs/libsdl[X,sound,video]
+ media-libs/sdl-mixer[wav]
+"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}/src"
-
-PATCHES=( "${FILESDIR}"/${P}-{build,sound,gcc6}.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-{build,sound,gcc6}.patch
+)
src_install() {
insinto /usr/share/${PN}