summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-12-23 15:12:29 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-12-23 15:12:47 -0500
commitf82deeafdd9ec33fd478eca1d9f981a8a2124525 (patch)
tree12ded1127da105d16698dc94e74f3b71e384d2ec
parentmail-filter/spamassassin: fix minor typo in comment and error message. (diff)
downloadgentoo-f82deeaf.tar.gz
gentoo-f82deeaf.tar.bz2
gentoo-f82deeaf.zip
mail-filter/spamassassin: new revision with fixed packlist.
SpamAssassin, being a perl package, installs a ".packlist" file. By default that file contains paths from ${D}, our temporary installation directory. This new revision adds a call to perl_fix_packlist() from the perl-functions eclass, which replaces those incorrect paths with the correct ones on the root filesystem. Package-Manager: portage-2.3.0
-rw-r--r--mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild (renamed from mail-filter/spamassassin/spamassassin-3.4.1-r9.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/mail-filter/spamassassin/spamassassin-3.4.1-r9.ebuild b/mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild
index 44e7f29ea5fa..9ba34fc1a7ac 100644
--- a/mail-filter/spamassassin/spamassassin-3.4.1-r9.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.4.1-r10.ebuild
@@ -213,8 +213,16 @@ src_install () {
update-spamassassin-rules
fi
- # Remove perllocal.pod to avoid file collisions (bug #603338)
+ # Remove perllocal.pod to avoid file collisions (bug #603338).
perl_delete_localpod || die "failed to remove perllocal.pod"
+
+ # The perl-module eclass calls three other functions to clean
+ # up in src_install. The first fixes references to ${D} in the
+ # packlist, and is useful to us, too. The other two functions,
+ # perl_delete_emptybsdir and perl_remove_temppath, don't seem
+ # to be needed: there are no empty directories, *.bs files, or
+ # ${D} paths remaining in our installed image.
+ perl_fix_packlist || die "failed to fix paths in packlist"
}
src_test() {