summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-23 14:51:30 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-23 14:52:41 -0500
commitf82f0445d369f9cb6121954030b2baf759c711b6 (patch)
tree8f433def4b9b9a1ef21dafd939602beff1d5fd6b
parentdev-python/prometheus_client: Stabilize 0.16.0 ALLARCHES, #896084 (diff)
downloadgentoo-f82f0445d369f9cb6121954030b2baf759c711b6.tar.gz
gentoo-f82f0445d369f9cb6121954030b2baf759c711b6.tar.bz2
gentoo-f82f0445d369f9cb6121954030b2baf759c711b6.zip
net-p2p/transmission: drop 4.0.0-r4, 4.0.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/transmission/Manifest1
-rw-r--r--net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch33
-rw-r--r--net-p2p/transmission/transmission-4.0.0-r4.ebuild147
-rw-r--r--net-p2p/transmission/transmission-4.0.1.ebuild140
4 files changed, 0 insertions, 321 deletions
diff --git a/net-p2p/transmission/Manifest b/net-p2p/transmission/Manifest
index c912d4124db9..c1f47b073e9c 100644
--- a/net-p2p/transmission/Manifest
+++ b/net-p2p/transmission/Manifest
@@ -1,3 +1,2 @@
DIST transmission-3.00.tar.xz 3995080 BLAKE2B fb1be44aa630e6a1cf15511ab4ab40156edb16f9410b83058c53548f466fb9502c23157756a29e921e4468db1ebac7832b755cfcf98451c663c64401559f5498 SHA512 c8fb96086ba4b18f04d6181a29f6e2af85864840c533f3470a202dfa686e9431caeccd25f12c975a9a8f9b7802ca0bd73c4edc1ca06bdbada682326cad188a76
-DIST transmission-4.0.0.tar.xz 10351556 BLAKE2B d0bb13437da6e6b6a9001eed7e59ce3f7b58151787e9c1057b0c6bf65dfdeaf89c3aedee563f641f6d2d2bd3a84dafa3f68b557b190bd323928578e811fb0183 SHA512 79945af73fe7226dddadba7cc039516f2f878e05a9cf6c6d799b636b8298e2b2fa25c4426789bd41ef4d2b00d75a3c1c115c1676b4d2a9f09a1526456dceb3f8
DIST transmission-4.0.1.tar.xz 10434832 BLAKE2B 6f5df293d804570f2a7bb1a13e2757eb643390d749cbfe238d8fdc5dccb829db29ff378ab767ecad89748a24de57e57dc34087f3a1fe7aad1dbdbc8f4b8af195 SHA512 a0226c96b08fd7be7cb9763132e36e59a4f84d67277c345860ac5a2e685ec0d5f2e8b3fe1e2d090e1180499518084de99387b822bb6dbdc1b7cb076d9a99ce05
diff --git a/net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch b/net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch
deleted file mode 100644
index 5fc3b5c1fcd7..000000000000
--- a/net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/transmission/transmission/pull/4807
-
-From 2c54813738ae5f9a3e2f99ffb86ed0858a5b3760 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 10 Feb 2023 17:55:54 -0500
-Subject: [PATCH] cmake: pass --no-warn-unused-cli to child cmake process
-
-Hides a warning when building the dht library.
-
-CMake Warning:
- Manually-specified variables were not used by the project:
-
- CMAKE_CXX_FLAGS
- CMAKE_INSTALL_LIBDIR
----
- cmake/TrMacros.cmake | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/cmake/TrMacros.cmake b/cmake/TrMacros.cmake
-index 4b84c0af9..46643ff76 100644
---- a/cmake/TrMacros.cmake
-+++ b/cmake/TrMacros.cmake
-@@ -168,6 +168,7 @@ macro(tr_add_external_auto_library ID DIRNAME LIBNAME)
- PREFIX "${${ID}_PREFIX}"
- CMAKE_ARGS
- -Wno-dev # We don't want to be warned over unused variables
-+ --no-warn-unused-cli
- "-DCMAKE_TOOLCHAIN_FILE:PATH=${CMAKE_TOOLCHAIN_FILE}"
- "-DCMAKE_USER_MAKE_RULES_OVERRIDE=${CMAKE_USER_MAKE_RULES_OVERRIDE}"
- "-DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}"
---
-2.39.1
-
diff --git a/net-p2p/transmission/transmission-4.0.0-r4.ebuild b/net-p2p/transmission/transmission-4.0.0-r4.ebuild
deleted file mode 100644
index 98ed72317d7d..000000000000
--- a/net-p2p/transmission/transmission-4.0.0-r4.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 2006-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic tmpfiles systemd xdg-utils
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/transmission/transmission"
-else
- MY_PV="${PV/_beta/-beta.}"
- MY_P="${PN}-${MY_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/transmission/transmission/releases/download/${MY_PV}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-fi
-
-DESCRIPTION="A fast, easy, and free BitTorrent client"
-HOMEPAGE="https://transmissionbt.com/"
-
-# web/LICENSE is always GPL-2 whereas COPYING allows either GPL-2 or GPL-3 for the rest
-# transmission in licenses/ is for mentioning OpenSSL linking exception
-# MIT is in several libtransmission/ headers
-LICENSE="|| ( GPL-2 GPL-3 Transmission-OpenSSL-exception ) GPL-2 MIT"
-SLOT="0"
-IUSE="appindicator cli debug gtk nls mbedtls qt5 systemd test"
-RESTRICT="!test? ( test )"
-
-ACCT_DEPEND="
- acct-group/transmission
- acct-user/transmission
-"
-BDEPEND="
- virtual/pkgconfig
- nls? (
- gtk? ( sys-devel/gettext )
- qt5? ( dev-qt/linguist-tools:5 )
- )
-"
-COMMON_DEPEND="
- >=dev-libs/libevent-2.1.0:=[threads(+)]
- !mbedtls? ( dev-libs/openssl:0= )
- mbedtls? ( net-libs/mbedtls:0= )
- net-libs/libnatpmp
- >=net-libs/libpsl-0.21.1
- >=net-libs/miniupnpc-1.7:=
- >=net-misc/curl-7.28.0[ssl]
- sys-libs/zlib:=
- nls? ( virtual/libintl )
- gtk? (
- >=dev-cpp/gtkmm-3.24.0:3.0
- >=dev-cpp/glibmm-2.60.0:2
- appindicator? ( dev-libs/libayatana-appindicator )
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtnetwork:5
- dev-qt/qtdbus:5
- )
- systemd? ( >=sys-apps/systemd-209:= )
-"
-DEPEND="${COMMON_DEPEND}
- nls? ( virtual/libintl )
-"
-RDEPEND="${COMMON_DEPEND}
- ${ACCT_DEPEND}
-"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/transmission-4.0.0-cmake-unused.patch"
- )
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
-
- -DENABLE_GTK=$(usex gtk ON OFF)
- -DENABLE_QT=$(usex qt5 ON OFF)
- -DENABLE_MAC=OFF
- -DENABLE_WEB=OFF
- -DENABLE_CLI=$(usex cli ON OFF)
- -DENABLE_TESTS=$(usex test ON OFF)
- -DENABLE_NLS=$(usex nls ON OFF)
-
- -DRUN_CLANG_TIDY=OFF
-
- -DUSE_GTK_VERSION=3
- -DUSE_SYSTEM_EVENT2=ON
- -DUSE_SYSTEM_DEFLATE=OFF
- -DUSE_SYSTEM_DHT=OFF
- -DUSE_SYSTEM_MINIUPNPC=ON
- -DUSE_SYSTEM_NATPMP=ON
- -DUSE_SYSTEM_UTP=OFF
- -DUSE_SYSTEM_B64=OFF
- -DUSE_SYSTEM_PSL=ON
- -DUSE_QT_VERSION=5
-
- -DWITH_CRYPTO=$(usex mbedtls mbedtls openssl)
- -DWITH_INOTIFY=ON
- -DWITH_APPINDICATOR=$(usex appindicator ON OFF)
- -DWITH_SYSTEMD=$(usex systemd ON OFF)
- )
-
- # Disable assertions by default, bug 893870.
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newinitd "${FILESDIR}"/transmission-daemon.initd.10 transmission-daemon
- newconfd "${FILESDIR}"/transmission-daemon.confd.4 transmission-daemon
-
- if use systemd; then
- # Service sets Type=notify
- systemd_dounit daemon/transmission-daemon.service
- systemd_install_serviced "${FILESDIR}"/transmission-daemon.service.conf
- fi
-
- insinto /usr/lib/sysctl.d
- doins "${FILESDIR}"/60-transmission.conf
-
- newtmpfiles "${FILESDIR}"/transmission-daemon.tmpfiles transmission-daemon.conf
-}
-
-pkg_postrm() {
- if use gtk || use qt5; then
- xdg_desktop_database_update
- xdg_icon_cache_update
- fi
-}
-
-pkg_postinst() {
- if use gtk || use qt5; then
- xdg_desktop_database_update
- xdg_icon_cache_update
- fi
- tmpfiles_process transmission-daemon.conf
-}
diff --git a/net-p2p/transmission/transmission-4.0.1.ebuild b/net-p2p/transmission/transmission-4.0.1.ebuild
deleted file mode 100644
index 359413eb1aa0..000000000000
--- a/net-p2p/transmission/transmission-4.0.1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 2006-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic tmpfiles systemd xdg-utils
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/transmission/transmission"
-else
- MY_PV="${PV/_beta/-beta.}"
- MY_P="${PN}-${MY_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/transmission/transmission/releases/download/${MY_PV}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-fi
-
-DESCRIPTION="A fast, easy, and free BitTorrent client"
-HOMEPAGE="https://transmissionbt.com/"
-
-# web/LICENSE is always GPL-2 whereas COPYING allows either GPL-2 or GPL-3 for the rest
-# transmission in licenses/ is for mentioning OpenSSL linking exception
-# MIT is in several libtransmission/ headers
-LICENSE="|| ( GPL-2 GPL-3 Transmission-OpenSSL-exception ) GPL-2 MIT"
-SLOT="0"
-IUSE="appindicator cli debug gtk nls mbedtls qt5 systemd test"
-RESTRICT="!test? ( test )"
-
-ACCT_DEPEND="
- acct-group/transmission
- acct-user/transmission
-"
-BDEPEND="
- virtual/pkgconfig
- nls? (
- gtk? ( sys-devel/gettext )
- qt5? ( dev-qt/linguist-tools:5 )
- )
-"
-COMMON_DEPEND="
- >=dev-libs/libevent-2.1.0:=[threads(+)]
- !mbedtls? ( dev-libs/openssl:0= )
- mbedtls? ( net-libs/mbedtls:0= )
- net-libs/libnatpmp
- >=net-libs/libpsl-0.21.1
- >=net-libs/miniupnpc-1.7:=
- >=net-misc/curl-7.28.0[ssl]
- sys-libs/zlib:=
- nls? ( virtual/libintl )
- gtk? (
- >=dev-cpp/gtkmm-3.24.0:3.0
- >=dev-cpp/glibmm-2.60.0:2
- appindicator? ( dev-libs/libayatana-appindicator )
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtnetwork:5
- dev-qt/qtdbus:5
- )
- systemd? ( >=sys-apps/systemd-209:= )
-"
-DEPEND="${COMMON_DEPEND}
- nls? ( virtual/libintl )
-"
-RDEPEND="${COMMON_DEPEND}
- ${ACCT_DEPEND}
-"
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
-
- -DENABLE_GTK=$(usex gtk ON OFF)
- -DENABLE_QT=$(usex qt5 ON OFF)
- -DENABLE_MAC=OFF
- -DENABLE_WEB=OFF
- -DENABLE_CLI=$(usex cli ON OFF)
- -DENABLE_TESTS=$(usex test ON OFF)
- -DENABLE_NLS=$(usex nls ON OFF)
-
- -DRUN_CLANG_TIDY=OFF
-
- -DUSE_GTK_VERSION=3
- -DUSE_SYSTEM_EVENT2=ON
- -DUSE_SYSTEM_DEFLATE=OFF
- -DUSE_SYSTEM_DHT=OFF
- -DUSE_SYSTEM_MINIUPNPC=ON
- -DUSE_SYSTEM_NATPMP=ON
- -DUSE_SYSTEM_UTP=OFF
- -DUSE_SYSTEM_B64=OFF
- -DUSE_SYSTEM_PSL=ON
- -DUSE_QT_VERSION=5
-
- -DWITH_CRYPTO=$(usex mbedtls mbedtls openssl)
- -DWITH_INOTIFY=ON
- -DWITH_APPINDICATOR=$(usex appindicator ON OFF)
- -DWITH_SYSTEMD=$(usex systemd ON OFF)
- )
-
- # Disable assertions by default, bug 893870.
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newinitd "${FILESDIR}"/transmission-daemon.initd.10 transmission-daemon
- newconfd "${FILESDIR}"/transmission-daemon.confd.4 transmission-daemon
-
- if use systemd; then
- # Service sets Type=notify
- systemd_dounit daemon/transmission-daemon.service
- systemd_install_serviced "${FILESDIR}"/transmission-daemon.service.conf
- fi
-
- insinto /usr/lib/sysctl.d
- doins "${FILESDIR}"/60-transmission.conf
-
- newtmpfiles "${FILESDIR}"/transmission-daemon.tmpfiles transmission-daemon.conf
-}
-
-pkg_postrm() {
- if use gtk || use qt5; then
- xdg_desktop_database_update
- xdg_icon_cache_update
- fi
-}
-
-pkg_postinst() {
- if use gtk || use qt5; then
- xdg_desktop_database_update
- xdg_icon_cache_update
- fi
- tmpfiles_process transmission-daemon.conf
-}