summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-31 08:27:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-31 08:53:00 +0100
commitf84ebc00512c880d462efcacb77faedf53e81754 (patch)
tree638ef7d5134bb462c07ab81d84a635e9bbe91ca2
parentdev-python/agate-excel: Bump to 0.3.0 (diff)
downloadgentoo-f84ebc00512c880d462efcacb77faedf53e81754.tar.gz
gentoo-f84ebc00512c880d462efcacb77faedf53e81754.tar.bz2
gentoo-f84ebc00512c880d462efcacb77faedf53e81754.zip
dev-python/pytest-env: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index 320e0b022b84..edef33a078cb 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1,2 +1,3 @@
DIST pytest_env-1.0.1.tar.gz 7565 BLAKE2B 26aa1c6a5d44bbe40266bbb62ca62c687dd1d85aed821c271f301ff27a97fdc753d2cdf5feba8b223b33b5b05bf39c55c3df0f1f8f7aae77335f2052a65df6c0 SHA512 422aaa78e25fad7b447f06358b772cacf22d5441ae0aaac22863877424f44703c1329813b068d901d4f2fb9df21bb08a5e4082504b76102d02dd15087d527a01
DIST pytest_env-1.1.0.tar.gz 8640 BLAKE2B 384b438c6a5da2ddeac0be1a601b74eca77abbe5b5100322f9f161f5e68119980370aa1c8f8160ca9db53628209742afabd981678784e2c42a1f527344c39558 SHA512 12fb8d1093f9d9e89a2bb543428086cba04a322a4d443960d3ab33f270a3aa8f98585c334091d90febe3a5f4d4d66111dd5a8a5a7322185af10cae3eae14bfde
+DIST pytest_env-1.1.1.tar.gz 8625 BLAKE2B e455f4183a7c423895f69e8a598c2fd312594501855b650008960cd94757aed4e2cf96302974bd68777a4a75e4363e3facc77ac9ac8a79f11f709f172852d105 SHA512 dffe17d1e7a2f0a8d26fd13ebc5f87ee834f03cbcf9870899952c306bdefafd9b3bc8f6120142c22d82cace28ee6b681e40b8eb71cd3c77781bf56c269c28feb
diff --git a/dev-python/pytest-env/pytest-env-1.1.1.ebuild b/dev-python/pytest-env/pytest-env-1.1.1.ebuild
new file mode 100644
index 000000000000..407864cef54b
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}