summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-17 11:34:08 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-28 15:15:21 +0200
commitf852c290ad649e8a299e285dae1d51fb55ded064 (patch)
treeca790ee3376be2f8b475912ed01164f4fcd220ef
parentmedia-libs/mesa: [llvm_targets_AMDGPU] is also required by r600 (diff)
downloadgentoo-f852c290.tar.gz
gentoo-f852c290.tar.bz2
gentoo-f852c290.zip
media-libs/mesa: Fix LLVM dep to pull exactly one version
Since LLVM is slotted, you can't expect multiple different dependencies to apply to the same slot. For this reason, we need to ensure that only one form of dependency (set of USE flags) is applied to LLVM. To cover all the necessary variants: - when using [opencl], enforce LLVM version and USE flags through implicit dependency via sys-devel/clang; - enforce [llvm_targets_AMDGPU] for all variants needing it, and the non-AMDGPU version only if neither of them applies.
-rw-r--r--media-libs/mesa/mesa-9999.ebuild55
1 files changed, 45 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 0a378a1ffeb8..61bcd2822dbb 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -143,18 +143,53 @@ RDEPEND="${RDEPEND}
RDEPEND="${RDEPEND}
llvm? (
opencl? (
- >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP}]
- )
- video_cards_r600? (
- >=sys-devel/llvm-3.9.0[llvm_targets_AMDGPU(-)]
- )
- video_cards_radeon? (
- >=sys-devel/llvm-3.9.0[llvm_targets_AMDGPU(-)]
+ video_cards_r600? (
+ >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP},llvm_targets_AMDGPU(-)]
+ )
+ !video_cards_r600? (
+ video_cards_radeonsi? (
+ >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP},llvm_targets_AMDGPU(-)]
+ )
+ )
+ !video_cards_r600? (
+ !video_cards_radeonsi? (
+ video_cards_radeon? (
+ >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP},llvm_targets_AMDGPU(-)]
+ )
+ )
+ )
+ !video_cards_r600? (
+ !video_cards_radeon? (
+ !video_cards_radeonsi? (
+ >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP}]
+ )
+ )
+ )
)
- video_cards_radeonsi? (
- >=sys-devel/llvm-3.9.0[llvm_targets_AMDGPU(-)]
+ !opencl? (
+ video_cards_r600? (
+ >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP},llvm_targets_AMDGPU(-)]
+ )
+ !video_cards_r600? (
+ video_cards_radeonsi? (
+ >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP},llvm_targets_AMDGPU(-)]
+ )
+ )
+ !video_cards_r600? (
+ !video_cards_radeonsi? (
+ video_cards_radeon? (
+ >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP},llvm_targets_AMDGPU(-)]
+ )
+ )
+ )
+ !video_cards_r600? (
+ !video_cards_radeon? (
+ !video_cards_radeonsi? (
+ >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}]
+ )
+ )
+ )
)
- >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}]
)
"